Engineer Challenges no longer unlocking

I completed my engi challenges awhile ago but my friend is now having difficulties with completing them for the last 2 days.

1.) Field Trials - Complete a mission killing enemies only with the Crank Gun.
We’ve tried this 5x last night and he never got his challenge despite only using his crank gun for the whole mission.

2.) Tinkerer’s Tempo - Successfully maintain max Pressure for the Crank Gun as it is about to drop 100 times.
We tried this alongside #1 and even though he spent the entire map cranking, he got nothing.

3.) I Love the Smell of Black Powder - As the Outcast Engineer, shoot an ignited explosive barrel and have it kill 20 enemies.
Into the Nest Legend + Twitch + Send in the next wave Deed, there was definitely more than 20 rats in the tight hallway and despite them all blowing up, he didn’t get his challenge completed.

I know there were 2 challenges that were recently “fixed” but please make sure you didn’t actually break the other challenges. My friend has 12 left to do but the above challenges were the only ones we focused on last night and none of them were counting despite him doing the challenge correctly.

We’re not even going to attempt the others because there’s no point in wasting time if the challenges are broken. Please check all of the engi challenges and make sure they are working.

Please make sure you’re using the correct Steam version. We can’t have another “CBT Sorry cannot replicate your issue because whoops we used the wrong version” scenario again.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu