Enemies immune to damage and ignore block

Issue Summary: This happens about half the time when I join a game and the map is loading (not a lobby before the map loads)

Maybe more than half the time, enemies are completely immune to my attacks (pushes included) and they attack me through block. I am simply a moving target. I can dodge, but have no ability to do any damage to them at all. Now after joining a game I run to the nearest enemy and try to do damage or push it. If it is immune I simply leave the game. It is really frustrating. It has only been happening recently. I have no changes to my game other than adding a few sanctioned mods


Steps to Reproduce:

  1. Join a game currently in progress
  2. Try to do damage/push enemies
  3. Leave game within 5 seconds

Reproduction Rate (Choose One):
Once
Rare (< 10%)
Unusual (< 25%)
Common (< 50%)
Often (< 75%)
Constant (100%)


Additional Information:


[Attach a Screenshot and/or Video Evidence]
(Screenshots and/or video evidence (if applicable) can be particularly helpful. To upload, click the ‘Upload’ icon within the post controls.)


ON PC:

[Attach Your DxDiag]
(Press ‘START’ and enter ‘DxDiag’. Select the DxDiag app and allow it to load. Once loaded, click the 'Save All Information…" button and save to a location of your choosing. To upload, click the ‘Upload’ icon within the post controls.)

[Attach Your Session Console Log]
(Navigate to C:\Users\YOURNAME\AppData\Roaming\Fatshark\Vermintide 2\console_logs and locate the log that corresponds with the particular session in which your issue occurred. To upload, click the ‘Upload’ icon within the post controls.)

This or similar issues was caused by a sanctioned mod a while back. Don’t remember which mod but troubleshooting by reverting changes (deactivating mods) would be a good first step. Don’t forget to update the thread if you find out what’s triggering it.

It’s the player list plus mod. Which is why hardly anyone uses it. Do a quick search here on the forums for “player list plus” and see all the issues it causes. It’s been broken since it was sanctioned and the creator even has a warning on the steam workshop page for it. It should not be sanctioned for the official relm. Do NOT use this mod.

I’m keen to know whether this is a result of the Player List Plus mod. Please keep us posted, OP.

Thanks for the reply @SmokerT69 - I will check to see if that is the issue. I don’t think I even have that one. I dont have them all, some seem completely unnecessary to me

Update: I had that mod yes, and am currently testing the game with it disabled from the launcher

Update:

Crashed again, this time with this in the log…

GUID: 8994248b-7d36-4757-9559-223b54e1f9dd
Log File:
Info Type:

[Script Error]: …s/mods/BotImprovements_Combat/BotImprovements_Combat.lua:152: attempt to index local ‘tutorial_ui’ (a nil value)

In not kidding, the crash is expected 100% of the time

Update: Yes, I am disabling the bot improvements mod and testing again…

Version 1.5 released today. Some mods will require updates. Recommend disabling mods for now.
This is kinda something to be expected with mods and game updates.

True @hanzy - good point. I found that disabling Bot AI Improvements mod helped in some way I think…

Still testing. I had a full game earlier (noobs tho, spreading out and dying - so was a fail) and not a single crash

The two differences were, no bot AI, and disabled Bot AI Improvements mod. Tho, even if the mod was active, it wouldnt be controling anything, as the game was full

This time, going in with bots, not players

@FatsharkJulia - Last update for this thread:

I tested with and without Player List Plus mod. No difference. Crashing continued, and I was still unable to see any games in the lobby list

The GOOD news is…

After disabling “AI Improvements - Combat” sanctioned mod, I was able to get through a full game. First with just bots, and as the level continued (Hunger in the Dark - Legend - which is the level I used to test all changes) with a full group. Not a single crash, we finished and all got back to the lobby.

I have no idea why this game is so sensitive to these mods, but this problem was a thing for me BEFORE 1.5 dropped, and now… hopefully… will be a thing of the past.

AI Improvements - Combat. Disabled. Forever lol

Thanks for the replies, and apologies for creating another thread regarding crashes. I had forgotten I created another

As a side note, and not related to crashing…

I sill can not see any games in the lobby list lol

Disabled ALL mods, and still no lobbies in the list…

I wonder whats up with that?

You need to restart steam for lobbies to show up. It’s a known bug that’s been reported, but everyone said they can see lobbies after doing a restart. And nearly all mods are causing issues right now. I had at least 8 crashes yesterday, and tons of people are reporting crashing. You even crash if you kill a SV while it’s climbing up right now on the weekly. As well as many other things.

It isnt restarting steam. I do that every time I load the game

I did however notice something unusual…

Under difficulty, the game would normally list the uh, difficulties…

Now, all I see is a ‘dash’ or - in every one…

Also, I can set the filter to be ‘all’ and see the list, but none are considered ‘joinable’ and therefore, even if there is a slot I can occupy, when selected, the join button is greyed out and unselectable

Definitely something fishy going on…

I’m saying, when you get that bug, restart steam and launch the game again. People said that fixed it for them. Otherwise, you’re shït out of luck.

I didnt reread the whole thread but did you try verifying game files?

@SmokerT69 I know what you are saying lol - I DO that already. I do that for just the reason you listed. I noticed that problem quite a while back. Restarting steam does not fix it

@hanzy - thats not the issue. Also done.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu