Disk Write Error at 62%

Despite having followed every piece of advice on the matter (bar reinstalling Steam, literally no other game has this issue, so I will not be going through that), the game will - without fail - hit a disk write error at 61-63% mark. About 20gb into the download. Only the first time I tried downloading did it actually download the whole thing, but then it instead had a disk write error when installing the game.

So now it’s always getting stuck at around 62% of the download.

Note that write errors in the steam client are generally speaking because your anti-virus is killing the download by locking the file. You’ll need to add whitelisting in your anti-virus to address this issue

Definitely done that. Even turned it off for the entire installation. Neither worked, it still refuses to download.

That’s really more of a Steam problem. Have you tried a different drive on your system?

That I have not, yet. Since it’s the only game doing it, and literally everything else is going through, I’m more inclined to believe it’s the game. But I suppose I will see if I can install it on another drive.

Note the game isnt doing anything when steam is installing teh game. Thus its either something with your steam install, the drive you’re installing to, or your anti-virus

You can also try running steam as an administrator as well

Did that as well. However, the good news appear to be that the game’s entirely fine with going somewhere I don’t want it – the C drive. Well, so long as it’s the only game, I guess it doesn’t matter. Now to see if the installation also goes through fine.

Thank you for the idea.

This is a Steam hiccup. You might want to check out: How to Fix the Steam Disk Write Error

Been going through basically all of the steps other than reinstalling Steam. But the game started working when I put it on another drive, I presume it’ll be fine and dandy once we hit actual release. I’ll continue testing as-is in the meantime.