Crashes from launcher, and launcher looks weird

We kindly ask that you complete the questions below. With this information, we can investigate your issue properly.

Crashes once I click play on the launcher. Also launcher only shows game title and play button.

Crash Report (If Applicable):
GUID: 7ce6c216-cdc3-4298-8b2f-101e47e3b050
Log File:
Info Type:

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

  1. Just clicking play
  2. Crash


Player ID:

Approx. Time of Issue & Timezone:
[11/20/2022, 12:40PM] Central

I think your launcher looks like this because WebView2 isn’t installed.

Using the ‘Verify Integrity of Game Files’ option should initiate that installation. Also please have a look here:

I’ve verified my game files a few times, and have WebView2 installed. The launcher still looks the same. I’ve also done all of the recommended fixes on all the different guides, nothing has worked or changed.

Can you try reinstalling dot net and deleting your appcache. Please reboot your system after trying the dot net reinstall

If you manually install webview2 do you receive any errors from the installer?

I get the error that says I already have it installed. Tried the reinstall and still the same problems. Also did all the things that guide said to, and it still won’t work.

Any other things I can try? would really like to play the game.

Can you try reinstalling DOT Net 4.8

Reboot after you repair or install dotnet

Also please upload any launcher log or console log files as well

Here are my logs, and it gave me a different GUID this time.

GUID: d5d5c9e8-4025-485a-af80-fbd063fc7589
Log File:
darktide_launcher.log (742.0 KB)

Info Type:
console-2022-11-22-21.27.40-4c4aa59e-3c11-4670-8290-cc6a49e42adf.log (26.1 KB)