Can't start the game with Patch anymore

I was able to play today before the Patch came out today, now when i wanted to play again it doesen’t work anymore. Haven’t seen anyone posting this problem yet so i really don’t know what happened.
I tried to disable mods and tried dx11 and dx12 but always when i start the official realm the little vermintide 2 logo appears and then it disappears and nothing happens, not even a crash notification.
The modded realm does work and the benchmark, but i want to play official realm.
Did verify game files with steam and deleted the appdata files, but still doesen’t work.

I believe this is something to do with our anti-cheat provider, Easy Anti-Cheat.

Could you please try repairing Easy Anti-Cheat using the EasyAntiCheat_Setup executable located here:

C:\Program Files (x86)\Steam\steamapps\common\Warhammer Vermintide 2\installers\EasyAntiCheat

It works now all of a sudden. I started a few other games and got steam cloud sync issue message, which was a little surprising aswell, then after few attempts the error was gone and i tried vermintide 2 and it started as it should.

Today i have the same issue again, did repair EAC already. Really annoying as this never happened in my 800 hours playtime so far. I have read aboud Telekom issues, but would be weird if this would be related to my problem i guess.

Assuming it still works in the modded realm, it’s more likely to be related to Easy Anti-Cheat. Then again, this Telekom issue has resulted in all kinds of weirdness, so I wouldn’t rule it out completely!

Could you please ensure the Easy Anti-Cheat service isn’t disabled by:

  1. Open the Command Prompt as an administrator
  2. Enter the command:
  3. Locate Easy Anti-Cheat within the list and double-click it
  4. Change ‘Startup Type’ to ‘Manual’ if it’s set to anything else

It is set to manual. The issue still occurs most of the time.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.