Cant see select mission or any selection menu since patch 2 is installed

I cant see select mission or any selection menu in the game since patch 2 is installed. A black screen came out but it is not freeze though. I press esc and continue the game.


Same exact problem, i can’t see:

  • video intro “there can be no victory for darkness always return”
  • any mission video intro (i can only see the rotating skaven logo in the bottom right corner of the screen)
  • mission pane (but i can interact with buttons that should be there)
  • talent pane (but i can see inventory, cosmetics and crafting pane)
  • okri’s pane
  • ranald loot calculation

I have AMD Radeon HD6900 series with windows 7 64bit


FYI : already tried to update AMD drivers

Have the same problem, also have AMD videocard.

It’s also worth mentioning that even though the screen is black, I can still see the mouse. It’s a very nice mouse, but it doesn’t compare to the in-game mouse.


Same exact problem and I have a AMD Radeon HD 6900 with a windows 7 64 bit…I also reinstalled vermintide and still have the same problem.

Same issue as bucointesta. I also have an AMD Radeon HD6900 with windows 8.1 drivers up to date. also tried to uninstall and reinstall still wont work.

I forgot the mention. I have “ATI Radeon HD 6850” video card and Windows 7 64 bit.

When I open the talents I can’t see talents tree but I can choose talents without see anything. So it means game is working fine except the list you made [bucointesta]

This is a known issue, apologies for the inconvenience.

If it is a known issue, doesnt it mean you guys are gonna fix soon?

Yes, our intention is to resolve the issue as soon as possible.

1 Like

I have same issue. This won’t fix it but it will allow you to play at least. Go to gameplay options and turn on controller menu (beta). you can then see mission select.

1 Like

This works, at least I can play :smiley:

Please resolve this issue ASAP, just bought the new extension and I can’t even play it that’s frustrating. I wanted to have my summer rat bash Holydays, but It’s almost ruined now…

same, problem.
the 2.06 haven’t fixed yet

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.