Can't enter game, inifinite load screen for Taals Keep

I am on PS4. I started a quickplay Chaos Wastes expedition but cancelled it while still in the keep, then a few seconds after the lobby closed I was “removed from the game for inactivity”. This sent me to an infinite load screen for Taal’s Horn Keep. The skaven symbol spins but it never actually loads. I closed the game and tried to re enter but was again stuck on this screen. I had been playing most of the day prior to this with no issues.

I tried waiting between 5-10 minutes on the load screen, restarted the game and the ps4 a few times, rebuilt the PS4 database, checked my router and its settings, and made sure the game was up to date to no avail.
The game will load in offline mode with normal load times, but trying to go online results in the never ending load screen

Oh no! Could you share your PSN ID with me please?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord