"Unrestful Bonefire" challenge not tracking properly

Issue Description:
“Unrestful Bonefire” challenge seems to not be tracking properly.

I’m running a build with “Barrow Blades” which gives the skeletons DoT attacks which should in turn be affecting enemies that they hit with “Malediction of Nagash” which should make any 2nd hit count towards the challenge.

I’ve played 5 matches with this talent and only gotten 5 hits which cannot be correct.

One of these matches was done with a loadout to maximize the amount of burning enemies for the skeletons to hit and that match only progressed the challenge from 4 to 5. This is coincidentally the amount of missions completed with necromancer.
Steps to Reproduce:
Play necromancer → have skeletons attack DoT affected enemies → confirm that challenge is not progressing properly.

Map Name (If Applicable):

Found on Steam but likely existing on all platforms.
Player ID:

Approx. Time of Issue & Timezone:
Right now. 5.1.0 Patch on PC.

Reproduction Rate:
Once - Rare (<10%) - Unusual (<25%) - Common (<50%) - Often (<75%) - Constant (100%)


Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

1 Like

Appears to only proc once per mission.

1 Like

Agreed, unrestful bonefire is not working properly. “Malediction” is any flame effect on enemies. I had a horde I set on fire with the staff and Skeletons guarded a hallway. Skels hit/killed almost all mobs on fire and I got 1 or 2 toward unrestful bonefire. Needs to be fixed please.

yeah i also have 18 mission completed with her and it says i only have 18/500 at unrestful bonfire as well XD

Tried burning the enemies and then commanding skellies to attack the burning ones, but it still doesn’t count. Seems to work once per level for me as well.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.