A Bitter Rose Among Thorns

Hi, for some reason missions that I am clearing with the new Elf class is not registering in my challenges. I however for some reason was able to get all the recruit/vet/champ/leg clears with the maps I did. Help please :C

I’ve added this to our database for investigation - I’d be keen to hear from anybody else experiencing similar issues with this particular Okri’s Challenge!

I’m experiencing the same issue as OP

I have same issue with that challenge

I just completed that challenge, I ran adventure maps only. Chaos Wastes and Weaves completions don’t count, I assume?

I’m talking about regular adventure maps

Do you know which maps didn’t count for you?

I presumed it could be just a specific map or group of maps.

I thought I’d try and help track down what the cause might be over lunch and ran 1 Helmgart and 1 Ubersreik map (legend) and both counted towards A Bitter Rose Among Throns.

It could ofc be less simple than this.

Cata Helmgart missions are not counting for me.

EDIT: To give more info, I’m always host also.

That challenge seems to register fine for me with normal adventure maps, but I think I was host 100% of the time. Maybe that has any influence on it?

However, the challenge I’m 99% sure is bugged is “Shall Not Pass”. I though I should have gotten it a few times when I killed a flying Assassin with the thorns on adventure maps, but it never registered. So I just tried to do it for about 20 minutes straight on Horn of Magnus’ Gutter Runner Stash, and I’m completely sure I killed several pouncing Assassins with the thorns to no avail. I even switched to normal thorn walls (as in: not the Bloodrazor Thicket because I thought it might maybe not count as a “wall”) with a strenght pot to kill pouncing Assassins, but that didn’t work either. Is it bugged or am I simply doing it wrong? Has anybody managed this challenge so far?

1 Like

I’ve finally got a map to count towards the challenge, once I dropped to Legend it registered

From the known issues page :

image

1 Like

I’m not sure how FS’s internal database works but it could be worth making a new thread stating that (some?) cata completions don’t count.

1 Like

For some reason I don’t remember how to edit my post so I’m replying.

My current conditions in regards to this challenge.

I have tried every single adventure map in the game on Cataclysm difficulty only. It does not fulfill as any mission completed.

Again to reiterate, I have gotten the completions for the recruit/vet/champ/legend clears challenges.

I have hosted every single time because everyone is playing the new elf career rn (lol)

It seems that according to tmack that dropping below cata difficulty will allow to get clears. Will reply again or edit if I find the edit button if it works.

edit Chaos wastes on cataclysm also does not seem to fulfill the requirement either. I do not play weaves.

edit2 Dropping down to legend got me 1 clear on the challenge. It seems Cataclysm difficulty is bugged for whatever reason.

1 Like

I believe only base missions count towards these kinds of challenges.
Chaos Wastes and Weaves don’t count for any other careers “complete X missions” unlockes.

Aaaah, that’s why I seem to have less maps completed than I felt I should have. Only the Legend runs counted.

And “good” to hear the challenge is indeed bugged. I thought I was hoing crazy…

After some cata runs

Have the same issue. I was Host the entire time and I ran Helmgart Maps and Dark Omens.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu