The last patch doesn't allow mouse look since I messed with the new aim assist. I can no longer play

PLEASE POST CRASHES AND ERRORS IN THE ‘TECHNICAL SUPPORT’ CATEGORY INSTEAD

We kindly ask that you complete the questions below. With this information, we can add it to our database for investigation.


Issue Description: Enabling the new aim assist settings stopped my game from working. I can not revert. Basically once you change aim assist with a controller, the mouse look will no longer work when using the controller (I have a disability, I need to use both and for the last 100 hours I have been able to do that until this patch.

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]
Play a normal game with KB/M. Plays fine.
Switch to a controller and go into settings and turn off aim assist.
Restart the game using a controller with a KB emulator like ReWASD. If you play with the controller, the mouse look stops working. I need both to play with and it worked in this game before I messed with Controller aim assist. It also works with all my other games.
It can be tested in the Morning Star.

  1. Play Chasm Logistratum as Ogryn (Skullbreaker)
  2. Navigate to the medical station before Burnside
  3. Crouch-slide into the dumpster next to the blue and white Tertium sign
  4. Get stuck

Mission Name (If Applicable):
Morning Star.

Platform:
[Steam/Microsoft Store]
Steam Windows 11.

Player ID:
[Steam ID/Steam Profile URL/GamerTag]
Masterblaster73. Steam Community :: ♂ TheBlasterMaster™ ✞

Approx. Time of Issue & Timezone:
[MM/DD/YYYY, 00:00AM/PM] [TIMEZONE]
04/06/2023

Reproduction Rate:
Once - Rare (<10%) - Unusual (<25%) - Common (<50%) - Often (<75%) - Constant (100%)
100% Can’t revert
Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log:

  1. Press the Windows key + R
  2. Enter
    console-2023-04-06-13.51.47-e5f01c48-525b-4474-b5a4-44767cbfd1ca.log (56.2 KB)
    console-2023-04-06-13.54.51-a9b4e032-b738-42b8-86b0-ce54234c6326.log (91.3 KB)
    darktide_launcher.log (689.4 KB)
    within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here

Upload darktide_launcher.log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Locate the darktide_launcher.log in this directory
  5. Upload here
    detailed problem description.txt (1.7 KB)

I’ve raised this for investigation, but in the mean time you may be able to “unbreak” it by wiping your AppData. This will clear any custom options including your keybindings:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark
  4. Delete the entire Darktide directory

If this doesn’t work, see whether Steam Cloud Save is interfering by auto-restoring it. This option is accessible by right-clicking Darktide in your Steam library, selecting ‘Properties…’ and see the ‘Steam Cloud’ option within the ‘General’ tab.

Thanks but I have tried that. It didn’t help. I wiped all the hidden files, uninstalled the game, turned off Steam cloud, and started over. The game still recognizes the controller now.
I could be wrong but a simple “disable Controller” in Control settings could work.

I tried both of your ideas and neither worked. I also went into Steam settings and deactivated the controller and the game still see’s it. Something in the last patch relating to changes to aim assist I believe did it.

Note in this pic, the game has not fully loaded and in the lower right corner an X which indicates the game has already recognized my controller.

Thanks for your help. I sure miss playing.

that x in the lower right corner is a keyboard x not a controller button x you can see the bottom left shows esc and the controller scheme should look like this

Ahhh,
I see, thanks. Still the same problem though. Trying to help them resolve this so I can play. Before this I was a daily player.

I am dead in the water and cannot play at all. I guess my Imperial edition wasn’t such a good investment. You can no longer use a controller and a mouse at the same time. This is now the only game I have that does this of my 174 games. Please fix.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Sorry for late reply.

I believe the issue is due to game believes we have more than one input (M/KB + Gamepad) and we switch which one to listen to all the time due to this.

I will see if we can make a fix.

if you still are interested of having a fix for this, please upload if there is a specific rewasd config we should try out.

Note I have never used rewasd. I will try reach out to them as well to see how this should work from their perspective.