Stuck in a rubberbanding/laggy movement unable to swap weapons etc

Charged as the ogryn, hit a regular doorway and got stuck in this odd rubberbanding movement. It was as if the keys kept getting held down as I kept walking after letting go.
Spamming attack, weapon swap, abilifites, all seemed to get canceled.
Out of hundreds of charges, only happened once. Fixed itself by reconnecting to the game, as I crashed going through another doorway.

Steam release.

I’m also having this rubberbanding / stuttering / lagaporting issue, but constantly, for the last 3 days. I will try to switch weapons, and the animation will begin, but then cancel. I’ll try to fire a ranged weapon, and the animation will play, as well as sound, but no ammo is consumed, and no hit is registered. I’ll be just running around the Mourningstar, but I’ll be cha-cha sliding all over the place and my character will do weird little blink teleports.

I should say I have tried every fix I can think of. Called my isp, reset my pc, verified files on Steam, uninstalled and reinstalled the game, tried changing settings in game, switched between borderless and fullscreen… Nothing seems to help, and the game is currently unplayable for me in this state.