Saltzpryre Ultimate stuck

Issue Summary: I was playing as Bounty Hunter on the Pit yesterday (joined through QP, don’t have the DLC) and ran into a CW. Ultimate was on cooldown, but with just a few seconds left, I decided to hold out and wait for the finisher. I started spamming F in the last two seconds while franctically backpedaling (no dodge). The Ultimate bar filled up, Saltz pulled his gun and… didn’t fire. I kept mashing F, but nothing happened, besides the CW finally putting me down with an overhead swing. Party members arrive to revive and as I get up, I notice the Ultimate pistol is still visible in the left hand. I tried firing it, but it didn’t work. Tried switching weapons with Q, but in the first few attempts, it brought up the melee weapon, before the Ultimate gun turned into an Ultimate hand (the pistol turned invisible). A bit more mashing and the melee weapon was finally available. After scoring a few kills with it, I could once again reliably switch to my regular ranged weapon.

Throughout the run, I didn’t notice any lag or latency related issues (I wasn’t the host), but nevertheless, I don’t discount the possibility that I was already downed by the CW on the host and just received the info late.

Steps to Reproduce:

  1. Quickly tap F seconds before the Ultimate bar is filled up.
  2. Have the gun out, but without the shot firing. Get stuck in the position without other weapons available.
  3. No idea how to reproduce, only happened once (only had time for a single run yesterday).

Reproduction Rate (Choose One):
Once
Rare (< 10%)
Unusual (< 25%)
Common (< 50%)
Often (< 75%)
Constant (100%)

Additional Information:
Sorry, I’m at work, can’t upload anything. Maybe it was a one-time bug, but what if it isn’t?

Thanks for the report. Certainly the first we’ve heard of this one. If it happens again and you spot any correlation to the events of this report, let us know what those circumstances were so we can try to replicate it and fix.

Thanks, I couldn’t replicate it so far. However, this took place in the Pit at the end of the sewer section (2nd Grim room), where there’s a ramp up and an opening in the wall to the right, which leads to the final area before the escape event. When Q-swapping weapon on the ramp, the switch felt wonky. I have no idea how terrain could have any effect on weapon-swapping and the Ultimate ability, but it felt like I got snagged for a moment (saw the underneath of the ramp for a blink).

Proper update, managed to almost replicate it. The way is easy, just spam F when the bar is almost filled up until it fill sup. The gun will come out, but might not fire. Might by a synching problem between host and clients.

This topic was automatically closed after 7 days. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu