[Proton] Crashes during login after last update

Issue Description:
Before the last updates, I was able to play on Proton Experimental / Proton-GE without problems, now it simply crashes after reaching the login screen, the loading icon freezes after few seconds and then crashes (no crash report dialog opens too).

I know you do not officially support Linux in general, but it used to work as on windows, I have the EAC Runtime installed and verified, I can play others EAC protected games normally, so I’m asking if maybe you have forgot to re-enable the support for Linux or you have disabled it entirely with the last updates.

Steps to Reproduce:
Launching the game from Steam, after the cut scene at the login screen simply pressing space then it crashes. (it happens with/without skipping all intros and cut scene)


Player ID:

Approx. Time of Issue & Timezone:
07:40:40 & CEST (UTC+2 hours)

Reproduction Rate:
Constant (100%)

Upload Console Log & darktide_launcher.log:
console-2023-08-11-19.42.04-cf7e991b-a9cf-4f4a-8c54-30bba1a67317.log (23.3 KB)
darktide_launcher.log (7.4 KB)

from attached log:

19:42:16.070 [LanTransport] Failed to bind the socket to port 0 with error code 0x002736.
19:42:16.070 [LanTransport] Failed to get socket buffer size. Error 10038

Error 10038 is 0x002736, which means that socket operation was perfomed on not a socket. check dmseg maybe app armour or some other smart fw blocked proton from opening a port.

reasons can be many, it could be code issue as well, for example this error happens when code tries to get ip address of either side of connection AFTER connection was closed. which could be code that break stuff under linux, but works under windows

1 Like

try running with PROTON_LOG=1

maybe then you gon a get some more info about what is going on?

some hints: Reddit - Dive into anything

1 Like

There is a small Linux community here - like the knowledgeable ggg above - who I hope will be able to help with this. Unfortunately we’re not able to dedicate any resource to investigating Linux-related issues at this time.

I have recently spoken to another Linux player who had to update Steam, in addition to the OS, to resume playing after running in to networking errors. I don’t know whether this could be of any relevance to you.

Thank you for your reply ^.^ I have checked everything on my OS and even router, nothing changed on my side, it simply happened after the latest patch (I played perfectly before), so we can “safely” start to thinking that this problem is on their side (engine and/or servers), even because on this forum another user has my same problems… everything I can do I suppose is waiting until the next patch, what’s strange though is that someone said to me that it runs on the steam deck… so I dunno honestly

Hello, I have both OS and Steam updated to the latest version, I have tried deleting the shader cache and everything useful you can find online… unfortunately nothing worked, I have been able to play perfectly until the latest patch.