Okri's Challenges - Prologue Bug

Issue Summary:

Ever since Okri’s Challenges were introduced to the game I was retroactively given credit for all of the challenge conditions that were met before the patch. except for the prologue mission. I went ahead and completed the prologue mission again and still no reward of challenges credit. Is this a known bug? How do get the “Complete Prologue mission” challenge to be marked as complete?

Steps to Reproduce:

  1. Login to game and check challenges
  2. Log out of game, login with different character, re-beat prologue mission
  3. Check again and the challenge is still marked was incomplete and no reward chest

Reproduction Rate (Choose One):
Constant (100%)

Additional Information: (see screenshot below)

Strange indeed. This was a little broken for some time but we fixed it some patches ago.

This reminded me to run the prologue on my home account to unlock the challenge and steam achievement to claim the box and it worked just fine for me. Could you share your Steam profile with me, if you prefer to through message that’s also ok, and we can have a look in to it for you.

It also worked for me. I played the prologue to get that box and it unlocked without issue in the current patch. I found a bizarre bug with Oleysya’s voice on the way.

Had the same problem after the bug fixes came out where it still didn’t work. Just tested though and worked.

This topic was automatically closed after 7 days. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu