Missions lock back up

No idea if this is actually a bug - or maybe I’m just stupid - but I can’t continue the game after “Empire in Flames”. The next mission does not unlock but “Empire in Flames” locks back up (means, I can’t pick it anymore). Nonetheless, it displays me “Empire in Flames” as my current mission. WTF?

Do the other maps unlock when you finish them? Against the grain for example? Are you playing in the modded relm or the official relm? Are you sure you’re not just getting the same mission over and over because you’re doing quick play? When you open the match maker menu (hit the “M”) button, click on custom game, can you choose the next map there?

1 Like

It’s the official realm. I played Against the Grain by hosting it (and making it through). Then Empire in Flames was unlocked, so I played this as well as hosted mission. After making it through though, a quick Play appeared. Where the party I was on failed. So, everyone logged out, I quit the game and realized, after trying again, that Empire in Flames was back to locked (yannow, where a mission symbol has chains around it and a lock in the middle). Nonetheless I could still play Empire in Flames (although it was locked, it just appeared as my current, chosen mission). Same thing again, played said mission, made it through, nothing. I just couldn’t get to the next mission (Festering Grounds, eh?).

Haven’t tried the match maker thingy yet. Instead, I picked Against the Grain again to see how things would progress this time. I mean, I have to in order to unlock a previously unlocked mission again

I’m not sure I understand… You played the mission and failed then did a quick play? And it got locked again? That’s weird. Can you take a screen shot of your missions and upload it here? If you don’t have a picture/video capture program, just hit the print screen button and chuck it in paint. Save it to desktop and you can upload it directly using this forum. On this forum reply box, the 7th icon from the left allows you to upload pictures.

Have you tried just picking the mission, doing a custom game. And then moving onto the next? If you need a hand clearing anything, add me to friends. My steam ID is smoker6969, my current gamer tag is Mayfly Lumberfoot.

No, I said I played “Against the Grain” and successfully made it through. The next mission would be “Empire in Flames” which I played and made it through again. The mission after that would be “Festering Grounds”, right? But it didn’t unlock like usually. Suddenly, after that mission a Quick Play was loaded (no idea if people on your team can actually do that as they please). Well, the team I hosted failed. So I quit the game. Just to see a little later, that the mission “Empire in Flames” was all locked up again, like I never made it through “Against the Grain”. Despite being locked, I still had the mission was my current one. I tried to play Empire in Flames a second time, same result, same sudden Quick Play appearence.

And no, I can’t upload a screenshot (although I pondered to). I simply went back to playing Against the Grain again, so the mission “Empire in Flames” of course disappeared as my current mission.

Ah, ok. That is weird. And yes, anyone in your keep can start a game. Doesn’t have to be the host.

1 Like

Ah okay. Anyway, I just managed to sucessfully make it through “Against the Grain” again (took me a while, I really hate that mission). And now it is getting weird. After checking for the next mission, I noticed both “Empire in Flames” and “Festering Grounds” are unlocked now. WTF?

Why not join the Fatshark Discord https://discord.gg/K6gyMpu