KNOWN ISSUE: Armory Exchange Flickering/Refreshing/Appearing Blank, Unable to Purchase, Or Displaying Only 2 Items

Same here, can’t progress in difficulty since I’m stuck using low level items and can’t purchase new ones

Happened to me too

I have the same problem since i went to look at the store at reset-time. Only two items are shown, which i also cannot purchase, because their trust-level is too high.

Mine’s started doing the same now.

the 2 that are showing are only green or one blue and lower lvl’s :frowning:

Just happened to me to as well. At level 25 advance on sharpshooter the shop started to give only 2 items to chose.

Apro time : 21.11.22 ~00:00.

For now its’ like 100% as I advanced next level & the shop changed for new 2 items :stuck_out_tongue:

Player ID : Steam Community :: BloodM3ss

Happened to me too with lvl 14 zealot(now i’m 17)
next level and the shop changed for new 2 items
Player id : Steam Community :: Patrik1020

I too have been stuck on lower power gear than advancement requires. I lucked out and got a good combat knife before it started, but I am level 18 now and for the last few levels I have been unable to purchase gear because of this bug.

Yep, I have the same problem.

Issue Description:
So i havent been able to purchase items due to the shop being on what it looks like to be an infinite refresh. I uninstalled and reinstalled and it still did that. I was able to purchase between levels 1-7. but after that the refresh occured. Hope this helps
Steps to Reproduce:

  1. Play Machete, Zealot Preacher
  2. Walk to armory after loading in
  3. go into the armory purchase menu
  4. the menu has you on permanent refresh. you cannot scroll, you cannot acquire.


Player ID:

Approx. Time of Issue & Timezone:
Reproduction Rate:
Constant - 100%

Upload Supporting Evidence:

Upload Console Log:
console-2022-11-19-10.39.13-a94dec88-f3a8-447b-8675-f64fc975128e.log (25.6 KB)

My acquisition shop does not refresh. Everytime I go into it it just remains blank. I have reset my windows clock multiple times, made sure it is automatic, manually synced it, and restarted my system with every refresh of the shop and still nothing.

Any solution would be much appreciated as I would very much like to upgrade my gear.

1 Like

Same … 2 times now. First time it came back after a LONG moment, now it’s gone again.

After a long read, I found a way for me to make it work again.
I’ve often read that you should set the time to automatic, but that was the case for me and that’s why I didn’t know what to do next.
I have now turned everything off and on again + then clicked on “sync now”. and everything works as before. (PC version)

  1. Right click on the clock
  2. Change date/time
  3. Set time automatically - off (was on)
  4. Set time zone automatically - off (was on)
  5. Set time automatically - back on
  6. Set time zone automatically - back on
  7. Synchronize clock time - click on the button “synchronize now”
    Then started the game again and now my shop works completely again.

I had the problem that the time was running but there were only 2 items left in the shop.

Only two items in my shop
Steps to reproduce:
None I guess, however another friend tried to connect to our full group game while we were in the finishing mission animation which caused all of our games to crash, after that my shop bugged.
Currently this bug is only on my Veteran Character.

Player ID:
My Steam ID

Approx. Time of Issue & Timezone:
21.11.22 15.07

Problem is constant
I have tried clock reset thingy, tried leveling up, nothing works.

Console Log:

console-2022-11-21-09.54.43-f8c3d695-2e5c-462e-98da-91b750042d51.log (864.3 KB)


launcher.config (82 Bytes)

EDIT: Nevermind, the issue has resolved by itself as I was editing the logs in.

My shop is completely empty now, now amount of fiddling with the clock is helping.

Edit: Uninstalling and reinstalling the game fixed the issue.

1 Like

For the past two days, my shop has either been completely empty, or only offers one or two weapons at most. Really disappointing not to be able to get new items like the chain axe or bolter. Also, every emperor’s gift I’ve received has been a grey item way below my level. Pretty sure that’s not intentional. Dunno why I would get a grey level 200 lasgun at level 25.

Store is still bugged after update and the date/time thing has NEVER worked for me.

Issue Description:

As the topic says my armoury is only showing two options, even after it refreshes it wont show more then two, it is also character specific as if i go to my sharpshooter all is well but on my ogryn then it will only show the two i did not skip the prologue of the sharpshooter and did skip the prologue of my ogryn (simply speculation: iam not sure if this is part of it but it seemed to start after i got some emperors gifts).
have tried restarting my game, syncing my time and date, restarting my computer, waiting for a refresh, changing characters, making a new character, deleting said new character.

Mission Name (If Applicable):

Steps to Reproduce:

  1. Open the armoury vendor on the affected character.
  2. Armoury shows two items and neither are my reputation level (ie my rep is 19, items are rep 20)


Player ID:

Approx. Time of Issue & Timezone:

Reproduction Rate:
Constant (100%)

Upload Supporting Evidence:

EDIT: since i forgot here is the newest log
console-2022-11-21-22.10.59-84df3120-38ed-466b-856e-d9f4718a6191.log (332.9 KB)

Just gonna ad to another topic like that had the same issue before & on another day it was back to normal armory.

today again got 2 items in shop…sadly.

Apro time & date : 22.11.2022 somewhere around ~01:00
[but cant say for sure as i changed to ogryn account to check if it also affected other characters & it was not ;then stayed playing him for a bit.]

My friend and I have been having this issue too. More than a few empty shops as well.