Game crashes when loading into Mourningstar with High Textures

The game crashes when loading into the mourningstar if using high textures. This did not happen before patch 1.0.30, am using Proton to play on Arch Linux. Using AMD CPU + GPU, Issue is happening on 5980HX + 6800M combo.

Issue Description
console-2023-02-23-05.37.17-8c3e45c3-9875-4c71-8f39-1e42e0e55ffd.log (46.9 KB)

Crash Report (If Applicable):
[Please see instructions on how to provide a crash report in the pinned Topic]

Error Displayed (If Applicable):

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

  1. Start Darktide
  2. Choose Character
  3. Load Game
  4. Crash

Mission Name (If Applicable):


Player ID:

Approx. Time of Issue & Timezone:
[02/23/2023, 00:45AM] [UTC -6]

Reproduction Rate:
Constant 100%

Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here

Upload darktide_launcher.log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Locate the darktide_launcher.log in this directory
  5. Upload here

I believe I have the same issue. See: Game crash on load since 1.0.31

We do not support Linux so unfortunately we won’t be able to look in to this. However, I have been informed that it may help to change deadlock_detector_enabled to deadlock_detector_false in the win32_settings.ini, which can be located in Steam\steamapps\common\Warhammer 40,000 DARKTIDE\bundle\application_settings.

Hey! That fixed it, thanks!

Note, I think this may have something to do with the hardware specifically rather than it being a Proton-Specific issue, I have a 6900XT at home I can test it on as well but I won’t be back until Friday night, I’ll report back to this thread when I find out. \

By chance, what does deadlock detector do anyways?

Just cross-referencing that I fixed a similar issue in a different way. See Game crash on load since 1.0.31

Tested it on my desktop and am disappointed to say that it does not work on the desktop, I am still required to use medium textures.

I really don’t think this is a linux specific issue, as I have had graphical issues with AMD on Windows when it comes to this game as well, is there anything else we could do to potentially fix this?

Fix doesn’t work on laptop either, turns out I didn’t have graphics maxed out. The game doesn’t like it when the settings are too high on AMD it seems, I will test this on Windows and see if the issue persists.

I can confirm that I have the same issue on Linux but not on Windows.
Proton: Proton-GE 7-49
Graphics: Mesa-git 23.1.0
OS: Arch Linux 6.2.2-zen
GPU: AMD Radeon 6800XT
CPU: AMD Ryzen 5900X
Memory: 32GB

The issue only occurred when I switched my graphics from “medium” to “high”.

console-2023-03-04-22.35.26-d53bd1ac-8b4a-4e7c-b460-ce4230042000.log (40.2 KB)
Crash Dump:
crash_dump-2023-03-04-22.35.26-d53bd1ac-8b4a-4e7c-b460-ce4230042000.dmp (9.4 MB)

Just in case a dev wants to sneak in a fix despite Linux not being officially supported.

Hopefully we do get a fix because I’m not gonna lie, You and I have 16gb of VRAM and it’s itching for usage. (We actually have similar specs, the only difference is that I use the stable mesa drivers and I have a 6900xt)

Are there any plans on this being fixed? The problem is starting to get worse, now I can only get one game in before my game crashes. It seems to be tied directly to loading into the mourningstar.

Unfortunately no resource will be dedicated to this as Linux is unsupported.

That is unfortunate. Even then, it would still be worth looking into as it may be a problem related to the GPU issues that people are having on Windows. Keep in mind that Proton is essentially like running Windows, games in Proton interact with the OS in very much the same way that they do on Windows. I’m not trying to hound you guys because I know you have your hands tied, but I think it is something that is worth looking into because the game has a decent following from players using Proton.

I will continue to monitor this issue and see if something within Proton or VKD3D fixes the issue, but I genuinely think it is something to do with the way the game is rendered rather than inherently being a “Linux” issue.

I’ll be damned, the bug was fixed with the latest update. Unless it was specifically fixed for proton, looks like it really was an issue on Windows itself.

By the way, thank you guys for continuing to work on this game. I know a lot of people in the community are giving you guys crap but no game ever really launches spot on nowadays, I think you guys are doing a good job, the crafting update was a great step in the right direction, keep up the good work!

1 Like