Game crash on load since 1.0.31

Sorry for posting a second time, but my previous post was removed by something called “kismet”. Please don’t remove it again.

Issue Description:
Since patch 1.0.31 I can no longer play the game. It was working fine yesterday before I updated to the latest 1.0.31 patch.

Now, when I start the game, after I have selected my character, and while loading the Mourningstar (the game hub), the game crashes. This happens every time I try.

My system is Steam, running on Arch Linux, with an AMD CPU and GPU, using the latest version of the Linux Kernel, and the latest AMD drivers. I have also tested two versions of Proton: experimental and 7.0-6 with the same results.

I have verified the integrity of the Darktide files via Steam.

Crash Report (If Applicable):

Steps to Reproduce:

  1. Start the game.
  2. Select character.
  3. Crash while loading the Mourningstar (game hub).

See above.

Approx. Time of Issue & Timezone:
2023-02-22 18:30 EST

Reproduction Rate:
Constant (100%)

Upload Console Log:
See above.

Upload darktide_launcher.log:
See above.

We do not support Linux so unfortunately we won’t be able to look in to this. However, I have been informed that it may help to change deadlock_detector_enabled to deadlock_detector_false in the win32_settings.ini, which can be located in Steam\steamapps\common\Warhammer 40,000 DARKTIDE\bundle\application_settings.

I’m sorry to hear that you do not support the Steam Deck. :slightly_frowning_face:

I’ve modified the following file as you suggested:

~/.local/share/Steam/steamapps/common/Warhammer\ 40,000\ DARKTIDE/bundle/application_settings/win32_settings.ini

Here is the modification I made:

deadlock_detector_enabled = true

was modified to

deadlock_detector_enabled = false

That did change the behavior of the game.

Now, after selecting my character, and while loading the Mourningstar, when the games freezes, it no longer crashes back to the desktop, but instead stays frozen forever. I had to forcefully terminate it to get back to the desktop.

So I reverted the change, and therefore I still can’t play the game anymore since patch 1.0.31.

Here is an update.

I upgraded to patch 1.0.31+ but it did not fix the issue.

However, the post of MasterFighterr Game crashes when loading into Mourningstar with High Textures gave me the idea that maybe it was a high quality texture settings issue. But, unfortunately, it’s not possible to change the video settings before loading the Mourningstar (or maybe I’m wrong?). So I dug a little bit and found that settings are saved in a configuration file in the following path:


So I made a copy of that file and then deleted it to reset all my settings.

That solved the issue. I can now play the game again.

I have not fiddled with the settings to figure out which one is problematic with the new 1.0.31 patch. But based on MasterFighterr findings, I suspect it is related to textures.

I hope this helps.

Here is my old buggy configuration file for reference:
user_settings.config (4.1 KB)