Festering Ground Challenge - Blessed by the Father

In order to do this challenge, you must be damaged by the bubbles’ pus in the final event… but at least two of them (I think they are always the same) don’t produce any pus.

I have had this also happen to me in previous attempts, very annoying indeed.

1 Like

They don’t count toward the challenge. I have completed it current build (and previous ones) and even though the buboes seem bugged the challenge is working as intended.


Now I have completed it too, this time these two bubbles haven’t counted… but I had to make more attempts.

I’ve tried this challenge four times in the last few days, and it does not work. Last attempt there were three or four buboes that produced no acid pool. This is nothing but an irritation.

In area 3, I’ve shot that high buboe from on the raised walkway, and from on the ground, and it never made a pool.

Stop wasting my time. That’s for me to do.

The one in the (edit) “ceiling” in area three is not landing underneath (which is quite stupid) but rather on the wooden walkway. You can melee it from a couple of boxes on the walkway and the pool is forming right next to them.

1 Like

This challenge has been bugged since the release of Okri’s Challenge.

Do not fret because you can still complete the challenge!!!

Note: it’s easier to complete with 1 other person but you can do it solo as well.

For the ones that are on the wall: have your friend shoot the buboe and as soon as it bursts, jump up towards it until you are able to touch the buboe. The poison on the buboe for some odd reason does count for the Okri’s Challenge.

For the ones that are on the ground, just stand really close to them and slap them with your melee weapon.

For the one above the boxes on the wooden plank (this is where having a friend is handy), have your friend shoot it and get as close to the edge of the boxes as you can without falling off of them. The poison actually does drop down on the boxes but shows no visual. This one took me 3 attempts to get right. When I tried to jump and melee this buboe, I kept missing the poison that fell down. If you have a friend and you stay still on the boxes, you won’t miss it.

I have completed this challenge last month and helped several other people complete this challenge. It’s really annoying but still doable.

Hope this helps!


I have done this challenge after many attempts, even if some bubbles haven’t produced acid… so it seems that sometimes these bugged bubbles don’t count.

Imho your problems is this part:

In area 3, I’ve shot that high buboe from on the raised walkway, and from on the ground, and it never made a pool.

That acid spawns over the wooden “bridge”, not on the ground.

Yep, after many attempts I had done this challenge… anyway thanks for your help!

1 Like

No problem at all!

Took me several attempts until I figured out a way to complete it! One of the more annoying challenges for sure!

1 Like

So I have a group of four who has recently finished all the Legendary Okri’s challenges for the base game (working on DLCs now) on the Xbox One. This achievement is our only exception.

Two of us who were able to unlock it, and did so on solo test runs after many, many failed attempts. Two more of us have yet to unlock it.

We’ve been experimenting like crazy to figure out exactly what unlocks this achievement on the console. Between us, we’ve must have run this level about two dozen times. There are definitely two buboes that never drop acid (as explained above) but very often there will be another random one that will not drop acid as well (or often two, making the total dud count four). I’m sure this definitely counts toward the issue, but even on runs where only the “common two” don’t drop acid, we’re still not getting the achievement to unlock as it should.

I was the first to unlock it, after about six or seven attempts. After that, I attempted to get it for another of my group repeatedly, with no luck. Each time we try, I use the same setup – Ironbreaker, making sure to get at least two ticks of acid damage so that Gromril’s Armor won’t mitigate the achievement. Had at least two runs of only “common two” failed buboes, doing everything as I should, yet no unlock for my partner. And each time, I did exactly the same things as my “successful” run – double tick of acid damage, partner visually verifying damage at each buboe, no deaths during run, etc.

Therein, its not just a missing acid splash or two causing this bug, because if it was, we’d be done a long time ago. Some other factor is causing this to not unlock consistently outside of the buboes not “aciding” properly.


Quick addendum – we’ve done a lot of experimentation on this as I like to build a strong bug report when I report problems like this (see Microsoft Store and Ultimate Edition issues from a few months back), but in this case, outside of some buboes not properly “aciding”, there is a factor preventing this achievement from popping that I cannot suss out via experimentation (at least not yet). Several “perfect” runs have led to no achievement unlocks, and there is no connecting issue we can ascertain.

If I do find something, I’ll report it here. Hopefully we’ll finish the remaining DLC achievements next week and can look into this again. As of now, we have spent WAY too much time trying to figure this mystery out.


So quick report – three of four have now unlocked this achievement. Apparently, running this map solo on Legacy has something to do with unlocking the achievement (our forth has yet to try running this solo, hence 3/4). We had a dozen attempts together as a group with no success, but solo everyone was able to get it within one or two tries.

So if you’re unable to unlock this, try running the map solo.


Good information.

4/4 now completed solo. 0/4 in any mix of a group.

1 Like

Is it possible that this is another host/client based issue? There are other things that work correctly for the host but not clients; I’m not sure of the reverse though.

1 Like

If you only look at Johnny’s experience that’s definitely not the case since host didn’t complete it either. I’m certain I’ve had successful completions for clients. I also know it has worked 3/4 times for me and people I’ve played it. 2/2 times when I’ve bathed and other people have gotten the challenge done.

1 Like

Definitely not a client issue as no one was getting the achievement grouped up, host included.

So if freqlectic was unlocking it with others in the party my theory is shot, but whatever is triggering it might be triggered by one or more people, so I would still try running it solo as that may reduce the probability of the bug not triggering.

Wish I could suss out more information on the bug, as I hate playing guessing on these things, but figured I’d share my theories here since that’s all we have at the moment.

Something that has reasonable chance of helping is to keep trying the Challenge and posting the session logs (both successful and bugged attempts) here. Might be useful to pick DxDiag file too. The instructions for both are found in this section (and the template for a new bug report).

If anyone want to actively look for the bug I’d suggest running it with someone else touching buboes puddles. Sounds weird that it would affect the challenge but it’s one of few reasonable explanations, since it’s something you wouldn’t normally check. As far as I can remember most runs have been “bather” only inside the different caves while the rest of the party has mostly been fighting by the cave openings. If you do it solo with bots, well bots can’t void challenges in my experience.