Crash when opening Okri's Book - Startet when I turned on Mods

Please include as much information as possible in the description of your issue and include:

  • Steps to reproduce the issue
  • How consistently the issue occurs for you
  • Screenshots and/or video evidence

If reporting a crash, please do so within the ‘Technical Support’ sub-category and include the crash report produced.

I played a few rounds with the Outcast Engineer yesterday, where everything seemed to be in order. I had turned of the mods I usually use, due to “Vermintide Mod Framework” telling me it was “Unsanctioned”.

Today I tried turning on the mods I normally use again and the game promtly crashed when I tried to open Okri’s Book. With the following error message:

GUID: 6cde896d-0bdd-4781-ae46-a3e8f722a128

Log File:

Info Type:


[Script Error]: …/views/hero_view/states/hero_view_state_achievements.lua:1893: attempt to index field ‘dlc_lock_hotspot’ (a nil value)


Crash Link:

crashify://6cde896d-0bdd-4781-ae46-a3e8f722a128

Mods I use (all should be Sanctioned):

  • Friendly Fire Indicator
  • Penlight Lua Libraries
  • Vermintide Mod Framework
  • Persistent Ammo Counter
  • Countries in Lobby Browser
  • Killfeed Tweaks
  • UI Improvements
  • Numeric UI
  • Skip Intro

AFTER TURNING OFF THE MODS I GET THIS ERROR MESSAGE WHEN TRYING TO USE THE BOOK:

GUID: e923e607-03d6-425a-ab0b-9a8c227bfd1e
Log File:
Info Type:

[Script Error]: …/views/hero_view/states/hero_view_state_achievements.lua:1893: attempt to index field ‘dlc_lock_hotspot’ (a nil value)

So something seems to point towards one of the mods somehow deleting or changing a file. I will try again after I have used Steams “Verify integrity of game files” function.

Update:

After validating the files Steam found an error in one file and redownloaded it. But opening the book still made the game crash with the same error. Still playing without mods here, I really shouldn’t have turned them on…

GUID: bc6bcd3b-41a6-44b7-99cb-31343edc1ee0
Log File:
Info Type:

[Script Error]: …/views/hero_view/states/hero_view_state_achievements.lua:1893: attempt to index field ‘dlc_lock_hotspot’ (a nil value)

Thanks for the report. This is a known bug with the Engineer release, and a fix should be coming soon! For the time being please avoid the quest book.

I tried verifying again and it found nothing, then I restarted the client and turned of “Penlight Lua Libraries” and “Killfeed Tweaks” (dependent on the Penlight) and now I can both play and use Okri’s Book :smiley:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu