Conservative Shooter Not Working With Throwing Axes?

So I had green Throwing Axes with Conservative Shooter on them, and it worked fine; every ranged headshot gave me a new axe.

But they were power 299, so I crafted new Throwing Axes of power 300. Rolled Conservative Shooter.
And now it no longer works! I can ranged headshot the dummy nonstop; I don’t get new ammo for it!

Was my old throwing axes bugged, or is the new throwing axe bugged?

Edit: It seems to work…when it wants too. I had a spare throwing axe lodged in the dummy’s head, which meant it gave me extra ammo at some point.
But I can’t make it proc, myself. It’s just completely random. And the axes are in the dummy’s head. I could do this nonstop before crafting the new axes.

Edit The 2nd: Logging out & back in fixed it so it’s registering headshots properly again. Weird.

There was also a graphical glitch where a spare throwing axe was detatched from my hand and hovering ant knee-height. I could just barely see it wriggling on the edge of my screen.
Don’t know if they were connected.

But it only happened when I crafted new throwing axes, then rerolled them for Conservative Shooter.

Edit 3: It happened again; broke during a mission.
I was getting headshot notifications, but not getting my 1.0 ammo back.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu