Chaos wastes: always-blocking boon does not always apply correctly

Situation:
Chaos wastes. Curse with the miasma+rod. Boon seemed to be working alright on previous levels, and worked fine at the start of this level. Melee weapon was out (Kruber, one handed sword) and shield icons displayed on screen. Boon was not on cooldown.

Observed behaviour:
Hits were taken without reducing stamina, dealing normal damage. Boon cooldown never triggered, as stamina was never depleted by attacks.

Expected behaviour:
Attacks would be blocked until stamina is depleted, and then the boon would deactivate for 10 seconds with a cooldown icon in the lower left.

Things that I did that may have caused the issue:

  1. Purchasing a random ranged weapon while melee weapon was equipped
  2. Picking up (and then dropping) the miasma-deflection-rod while my melee weapon was equipped.
  3. Picking up a barrel while the melee weapon was equipped. (however I think issue was present prior to doing this)

Strange things I noticed:

  1. After picking up a barrel and dropping it, the shield icons disappeared when my melee weapon was out. Blocking caused them to re-appear and stay there indefinitely. Not clear whether or not this fixed the issue, as I died very shortly thereafter.
  2. The boon did not apply when holding the rod, and I’m not sure if it should have, (but the boon was not working with my sword out.)

Will reply if I am able to reproduce this. Has happened just once.

I think you figured out the issue yourself there - the rod is not the exact same as a melee weapon. Whether or not you had your melee weapon equipped before you picked that, or a barrel up doesn’t matter, since you no longer have your melee weapon equipped when you are holding those; thus Vaul’s Anvil will not work.

As for the rod specifically, I’ve noticed that it does not generate temp health a little while back, I assume it is still the same. The rod does not appear to be classed in dependency terms as a melee weapon, and Vaul’s Anvil is dependent on you having a melee weapon in hand at time of use. I think this could be interpreted as a bug, seeing as you use it like a melee weapon, it looks like a melee weapon, so you would hope the game treats it like having a melee weapon out when you have Vaul’s Anvil.

It would be interesting to see if you can parry to get invulnerability with the other boon, using the rod.

This bug was observed under the following condition:

I am not reporting it not working with the rod, that was just a side observation. I’ll make sure that’s clear in the op.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu