Can't replace task a fourth time

Issue Description:
I rolled/replaced my task and on the fourth time, when it costs 7500, it won’t reroll. I can’t roll any other task either and the task I rolled is the only one I have tried to reroll. So in effect, there is a roll cap of three rolls on tasks. Since the task I tried to reroll has a cost and I haven’t rerolled any other task, I am assuming this is a bug

Steps to Reproduce:

  1. talk to Sire Melk’s Requisitorium
  2. Roll a task three times
  3. On the fourth reroll, 7500 gold, it will not reroll

Platform:
Steam

Player ID:
Ait

Approx. Time of Issue & Timezone:
11/22/2022, 01:30 AM GMT+1

Reproduction Rate:
I can check in six days. Right now I guess it’s in the category of rare if not other people can reproduce it.

Upload Supporting Evidence:
Not clear evidence, but I want to show it just so we’re on the same page.

3 Likes

yep same, with same conditions

I guess that bumps the repro rate right up to common then :stuck_out_tongue:

got the same… replaced task that gave me low income of the currency at end as it was “easy” & wanted to roll a bit for better one as money isn’t a problem after you level up to 30… but got stuck with medium quest for 7500 reroll but it was not working. Like the earlier problem with quest rerolls for 10k.

same, and it’s a water silo mission which doesn’t appear this week.

Platform:
Steam

Player ID:
ioulaum

Same, super annoying to see great weapons go by and not being able to get the 1000 for the weekly contract. Seems like an easy fix or thing to get right but its ok I guess

this hella anoying, not gonna reroll anything anymore atleast the initial quests are doable, the ones i got after rerolling are maps who aren’t even playable atm

Agreed, this issue is very annoying. Please fix.

same issue. rerolled a contract several times until it cost 7500. now i cannot reroll it anymore.

it is stuck on a quest to do 6 secondary objectives in Hab Dreyko.

You guys need to read sticky posts this is known you can only refresh them 4 times and its intended.

What a horrible design choice.

Same thing happening to me :frowning:

yeah me to & it makes you stop playing that class becosue if you do a shity 200 quest when you could easy reroll it for a better 400-500 & later when youy nead that bonus 300 to buy something in Meks shop :stuck_out_tongue:

Same issue here on steam, was hoping it was just a rare occurrence but I guess not!