Cannot apply certain illusions

Issue Summary:
I have 6 weapon illusions that cannot be applied. All other illusions in my inventory worked properly, but the remaining 6 do not.

Steps to Reproduce:

  1. select weapon
  2. select illusion
  3. click and hold “Apply Illusion” – the bar will “get stuck” when filled and never actually finish

Reproduction Rate (Choose One):
Constant (100%)

Additional Information:
The issue only occurs on these 6 illusions – I was cleaning out illusions and all other illusions in my inventory worked properly.

2 Likes

Could you shed light on which illusions they are, and if possible a link to your Steam profile so we can look in to this further? thanks!

Hi, I recently discovered this as well, and yes I made sure all careers did not have the same weapon equipped. I removed a ‘Soldier’s Coach Gun’ illusion from a Blunderbuss to hopefully apply it to a higher powered one and was unable to do so. This was also the case with the Huntsman’s Longbow as well. I removed a ‘Soldier’s Longbow’ illusion and had the same issue. One thing to note though, is the default weapon skin and illusion in both cases have the same name. Not sure if that is intended or just a bug. If there is no way of applying these illusions, can we at least have the option to salvage any that are removed in our inventory. Many Thanks!

Hedge, sorry I didn’t reply earlier; I assumed I would get an email notification if someone replied and hadn’t checked back on the forums for a few days. Here’s my steam profile:
https://steamcommunity.com/id/mahkraFUD/

I cleaned out all of my illusions a few days ago (which was a pretty tedious process – craft a bunch of weapons, then apply the illusions i had saved up, then scrap all of the weapons) so it would be easier to find the new purple illusions (which I’m applying to all of my power level 5 crafting templates :smile: ). The 6 bugged illusions are the only ones that are still loose in my inventory, not applied to a weapon:

elf longbow - glade guardian’s nastirrath
conflag - sputtering conflagration staff
dagger - tilcan paperweight (x2)
fireball - sputtering fireball staff
wizard sword - apprentice’s sword

I do periodically get back-end errors if I’m crafting too much stuff too quickly – possibly these are illusions that I got errors when trying to apply once & now the client & server don’t agree on something about them?

I don’t really care about these illusions. I would be happy to just have them deleted so they’re not cluttering up my inventory.

This topic was automatically closed after 7 days. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu