Weird Zealot Passive Bug

I was playing with Zealot the other day when I received enough dmg to kill me, so my passive activated but I died anyway. It was really weird. I posted the video onyoutube because it wouldn’t let me upload it here. Here is the video.
I use most of the QoL mods, and I was playing in the Official Realm. Ping was 80 at most, I played with zealot before at higher pings and this never happened.

PS: Also, blightstormers keep casting from behind walls in Enchanter’s Layer, mainly right after the second tome.

Edit: updated the video’s link because it was broken

The link to the video seems to broken.

Edit: Link now leads to functional YT video, all’s good.

Works for me, I dont know what to say.
It is this one: https://www.reddit.com/r/Vermintide/comments/jgyh57/weird_zealot_bug/

Well for me, the link leads to an empty page where the video doesn’t load.
I’ve tried Chrome, disabling µblock origin, internet explorer, new & old reddit and even tried a VPN yet the result is still an empty page.

I’d recommend youtube if you can, makes it easy.

mmm weird, guess I’ll upload it to yt then

It’s a client only issue(latency) where your passive doesn’t proc “in time” to save you.The higher your ping,the higher the chance for it to happen.Can easily see/reproduce this by running Feel Nothing and ulting straight into CW pat.Chances are,you’d die to an overhead even if the ult buff is up.There’s also issues with Bark Skin somewhat not working on high enough of a ping.

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu