Player List Plus Mod broken

EDIT: Solved this. It’s the Player List Plus mod that is broken. Disable it for everything else to work. OR make sure you have “smaller network packets” turned off under network settings

Issue Summary:

From what I can tell, the UI Improvement mod seems to be causes character to get stuck. When you try and switch your weapon, or change character, you get stuck forever and have to hard shut down the game through task manager. When trying to load Deeds, you get an actual message in the in game chat saying something along the lines of trying to load a nul factor or something. I should of took SS’s lol. I have to go now, but if it happens again later, I’ll take some SS’s and upload them.

Also, not sure if this is tied to the same bug. But when loading into peoples games in progress. You can’t deal any damage despite hitting the mobs and your block doesn’t work. You do the animation but nothing happens. On everyone elses screen you are just very glitchly crawling around on the floor.

Eh, so basically, if anyone joins my game, or if I join anyone else. When we try and quick play, half of us don’t get the screen to click accept, or we do and nothing happens. Also, if you try and open the challenge screen or change weapons, characters, we get stuck and have to hard close the game.

This is the error message my friend is getting in game now.

Can’t play any games right now. I’m going through the mods and turning them off one by one until I find the one that is broken. It turns out it’s not the UI improvement mod doing it right now or it’s that mod and another clashing or something.

i think It’s simple ui cuz i got rid of this bug after turning it off

Nope, just turned it off. Still get the issue xD Unless it still happens if the host has it as well.

Turned off all mods and it’s no issue. Going through and turning them on 1 at a time and trying to join my friends lobby to see which one it is.

Founded the problem. It’s Player List Plus that’s breaking the game.

https://steamcommunity.com/sharedfiles/filedetails/?id=1455893647&searchtext=

That error message I see in the chat is caused by the new DLC avatar frames. I have the same problem when I equip it on my careers. I don’t think however that the issue you are experiencing and the error message have something in common.

yea, it was the player list plus mod that was breaking the game. Works fine now

I am getting lots of errors in chat though. But it doesn’t seem to be effecting gameplay.

123123123

Hmm I haven’t see this particual error yet. Only the one with the missing dlc frame which pops up every time I open the inventory scree.
I guess you have the ‘Penlight Lua Libraries’ mod installed?

I can play with Player List Plus and …

I have absolutely non of the problems you mentioned so it must be something that I haven’t triggered yet even dough I played like half of the 25 quick plays like this or something on your side.

Quick plays are fine. It only triggers if you join a friends lobby, or join in progress on a friend. Try joining a friends lobby and then try to change character.

I disabled everything except for the mod framework and player list plus. Can confirm it’s that mod that is breaking the game.

That’s weird, I’m using that mod as well and have yet to encounter such issue.

Have you joined a friends lobby through steam and tried to change character?

Yeah

Encountered same thing. It is not just Player List Plus, it is combination of this mod and option “Small network packets” (or how it is called) turned on. After turning either mod or that option off issues disappear for me.

1 Like

I was able to switch hero after I already loaded the keep of my friend.
And trough the popup.

Interesting, I will have to try this. I was told to turn on “small network packets” by a Dev though to fix another issue. Even though I have 100MB up and down, this game has weird lag xD

it is a very strange bug though, if I quick play into games or host my own, I have no issues, it’s only when I join friends. If this is a “small network packets” issues, I think the Devs should take another look. They marked this thread “mod_Reated”. Which I guess it still is, but if an in game network issue is causing the problem. They might want to take another look.

@Fatshark_DarkkaneX

Why not join the Fatshark Discord https://discord.gg/K6gyMpu