Peer failed verification (2)

Issue Summary:
Receiving “Peer failed verification” exception while trying to play game.
Exception appear immediately or a few minutes after game starts.
Reproduction Rate (Choose One):
Constant (100%)

Previews topic was automatically please response faster.
Previews topic: Peer failed verification

Additional Information:

console-2018-09-07-22.29.28-31BCEB29-1DE3-4196-9A99-09E8.log (33.1 KB)

Stalk, please accept my apologies for not responding on the previous post. I’ve passed your console log over to one of our networking wizards who will hopefully be able to shed some light on this. I’ll be back in contact as soon as I have an update. :slight_smile:

Sure, thanks.

Hi again, could you inform me with issue status? I also had created request to EasyAntiCheat team because this error might be happen because of their application

Ok guys, I didn’t get any response from your side and it makes me feel upset. This issue doesn’t allow me to play this game about 2-3 months and here appear a question: “Why did I pay for this game?”. May be you could answer this game, or I should type an email to your general office and make refund for me and my friends?

Hey Stalk, I’ve chased for an update but unfortunately due to the weekend it’s unlikely we’ll hear back until tomorrow.

Thanks for the answer, will be waiting for status update tomorrow. If it help you can provide this information to developers or to your QA department:

  1. Game was reinstalled about 3 or 4 times and 2 times was a “clean” reinstall (we had deleted all data from steam common folder and from AppData\Roaming\Fatshark).
  2. We had tried after cleanup to add as a trusted files:
    a) Vermintide launcher
    b) EAC from Vermintide folder and from Program Files(x86)
  3. We had tried to repair and reinstall EAC 3 times. (Once we had even deleted and added FatShark certificate)
  4. We also has cheeked some file (I don’t remember tool name and file name) if it x64 type, I had found this issue in one of your topics, but it is ok.
    Exception appear right after initial screen movies with fatshark company logo and so on.
    waiting for your recommendations.
    Windows is licensed version with all updates and Russian localisation.
    As for me it looks like game cant pass authorization. User plays game through router (Router mode NOT bridge).

Thank you for the information. Unfortunately, this issue is proving harder to work out than we had hoped. Could you please check if this issue persists whilst connected to a VPN based in another country?

VPN doesnt work. Same error, we were using British servers and West Coast. Here is the last attempt console log:console-2018-10-01-18.46.09-749CBA55-657B-4410-A52F-3532.log (33.7 KB)

Hmmm, ok!

Without a VPN, could you please try accessing this URL: https://5107.playfabapi.com/

A blank page should be displayed, and it should be encrypted (‘Secure’ as seen in the screenshot beneath):

Encryption

Could you let me know what you see, please?

  1. At first has appear certificate error like this:
  2. After confirmation I was redirected to this page:
    Also i had received answer from EAC, nothing helpfull:
    Sorry to hear you’ve run into this issue!
    We recommend contacting the game support for assistance with it, as the error code you’ve encountered does not correspond to any of the codes used by Easy Anti-Cheat and is apparently related to the player’s connection to the game servers. The game’s support team will be able to tell you more regarding this matter. You can submit a support ticket to them here:
    https://en.kundo.se/org/fatshark/

Ok, so, something is redirecting your network requests to our servers. Could you please…

  1. Run the Command Prompt as an administrator
  2. Enter nslookup 5107.playfabapi.com

Then send me a message with the contents of the console, please?

Thanks for the screenshot Stalk, I’ve removed it as it contained some personal information.

The output from the console confirms your network requests to our servers are being redirected.

Unfortunately, we can’t solve this on our end. This could be malware, in which case we recommend scanning your PC for viruses and malware or this could be ISP-related. Also, do be sure the appropriate Firewall exceptions are in place for Vermintide 2.

Hello,
I also suffered from this issue, I believe switching to Google DNS solved this in my case:
https://developers.google.com/speed/public-dns/docs/using

Hope that helps!

Ok, guys. The problem has happen because of installed application Visual Studio.

Interesting, appreciate the update! Is everything working as it should be now?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu