Lohners cosmetic shop

Hi,

I’ve read several posts already about not being able to buy the new cosmetics in the store. I’ve seen these answered and tried all solutions;

Restarted the game, verified files and checked if the Steam Overlay is ticked on.

All of these are done and fine, and yet i cannot find the new cosmetics nor can i purchase them through Lohners shop. When i click ‘Acquire’, i’d wait about a minute or two, an authorization screen shows up from Steam that i confirm and then nothing happens. Then i tried several times, unfortunately, and nothing. But while i’m in a mission, i get absolutely spammed with authorization messages pop ups. That’s my bad for spamming it, but can i get a solution here?

Thanks!

We’re looking in to this right now, we suspect an issue with Steam. Sorry for the inconvenience.

Thanks for the reply and for looking into it!

I just bought the Shade cosmetic and had no issues.
Also, it has been reported before, but you should definitely switch the ‘Aquire’ button to ‘Owned’ once an item has been purchased :wink:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu