Lingering Flames talent for Battle Wizard not working?

Issue Summary:
Lingering Flames doesn’t seem to do what it says it does.

Steps to Reproduce:

  1. Choose Wizard
  2. Select Lingering Flames on level 10 talent row
  3. Loss of Profit

Reproduction Rate
Constant (100%)

Additional Information:
I have yet to notice any of my flames actually stay on the enemies with this talent. I tried a dot heavy Conflagration staff setup, but I didn’t notice any of the flames actually staying on. What’s the deal?

1 Like

Usually visual effect of flames fades right away.
To check if lingering flames are working - set enemy on fire and wait. If you’ll see hitmarkers appear - talent is working and enemy will die eventually.

1 Like

Worked in beta 3. Install “show damage” mod and go to modded realm for tests

It doesnt seem to actually work from my BW runs. Previously I’d get a few straggling kills from my DOT per map, not once did this happen now. Even using Beam with its strong dot component.

Can confirm it does not seem to work.

Here below, a clan rat burns seemingly for no longer than usual, and is still alive over 10 seconds after with lingering flames talent.

2 Likes

I was wondering about this too.

In Beta 3 I know it worked, I was able to confirm that. But in Beta 4 suddenly and mysteriously the enemies weren’t dying to it anymore.

I had originally thought it was just me, but when I ran BW with Conflag in LIVE I also noticed the same.

I would have never noticed if it wasn’t for the forum.
I’m reasonably certain I’ve seen enemies die several seconds after they’ve been hit. Not reliably, but they did.
Does it only not work on specific targets?
Edit: I did notice it more often when looking for it, though. It seems to me that sometimes, enemies just aren’t ignited even though there’s flames on them.

As far as I’m concerned it does not work against any enemy. Tried most, none work. The naked mole rats die fairly quickly, so hard to test on them, but all armored, elites amd bosses don’t get the permanent flame.

What weapon, though? I mostly tried with the Flameweave staff, and it seems to work against everything unarmoured. The armoured things generally don’t ignite even if they are visibly burning, but I get the occasional Stormvermin die to it. It is pretty common that these don’t die from it, though. Maybe it’s less noticeable on that staff because it hits so often, and fails versus armour anyways?
Edit: It definitely is working. Maybe not all the time, but often enough. The problem to me seems to be more on the side of ignites. It often doesn’t.
The talent is probably a bit strong, though.

I feel like it works intermittently. I tend to play with either the Beam Staff or the Fireball staff.
I’ve had instances where I lit a group on fire from across the map, I saw a flame animation on all of them; yet for some of them the animation disappears. To complicate matters further, I’ve also seen instances where the burning animation disappears, but then the rat still end’s up burning to death.

I can kinda accept that (because of rendering resources) they might not keep all the flame animations going. But I would really like to be able to operate under the assumption that, if I saw a rat burn, even if the animation goes out, he will still burn to death.

The only way I’ve found lingering flames to not work is dying, getting ressed and then trying to apply a DoT on an enemy you already used to have a DoT on.

Regarding that youtube video, flamestorm light attack doesn’t have a DoT.

I’ve been using it with flamewave, and it does seem to work most of the time but sometimes not. Definitely working on bosses, I’ll light them once and then go deal with horde and still end up with a decent chunk of boss damage at the end screen. Lighting a patrol of stormvermin and then running resulted in some of them eventually dying and some not, so I might have just missed a few. Against chaos warriors I don’t think it works, but I didn’t want to wait for an eternity to find out…

Could also be a host/client thing, I usually host.

Thats really what I’ve seen Flint,

Its like its very inconsistent. Sometimes its definitely working, then the next time it just wont. Its almost like some enemies get excluded.

Its like it just doesn’t proc sometimes.

1 Like

I’ve been playing for a while, mostly usimg fireball, confla, and flameweave staves and I have yet to see it properly work. I do still think that there has to be an issue with the talent, either on how it is worded or how it works.

I’m very interested to see, could you try and get some footage on you burning a boss? I’ve tried plenty of times but can’t seem to make it work.

1 Like

Sure thing I’ll be on tonight so I’ll get some boss burning footage

Well I forgot I hadn’t set up recording stuff since last time I wiped my computer so no video, but I did turn on damage numbers and do a bunch of testing in mod realm. TLDR: lingering flames are working on all enemies except for Chaos Warriors and other super armor (which I think is by design). I played several rounds and it worked reliably on all other enemies. Of course I was hosting the entire time so there could be client issues.

Most of the time the flame animation would disappear but the damage would keep ticking. Funnily enough on Chaos Warriors the flame animation stays but they take no damage.

On regular armor units like SV it works, the DoT is just super low at 0.75 per tick. it ticks reasonably fast but still on a 40hp critter that takes awhile.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu