Keybind bug - press "enter" to open chat window

Hello,

I’ve been playing Vermintide 2 for a while now. I’ve always been able to hit “enter” to type a chat message and send it. However, it’s not working anymore. I’ve been into my keybinds and tried rebinding to another key, I’ve reset to default, removed all mods, and still nothing.

What got broken? I didn’t see a patch recently.

This occured when Penlight Lua Libraries and Crosshair Customization became “unsanctioned” and yes, I tried to rebind when no mods are loaded… so, what’s next to troubleshoot?

Hard to read the achievement I just unlocked with Witch hunter in Chaos Wastes when I can’t open my chat box to review message.

Thanks,
Vormar Mishap

Hm, that’s strange. I haven’t seen this widely reported either.

There was an issue with Penlight Lua Libraries, however this should be resolved very soon!

It’s a bit of a stab in the dark, but perhaps it’s worth trying Verify Integrity of Game files -

  1. Right-click Vermintide 2 in your Steam library sidebar
  2. Select ‘Properties’
  3. Select the ‘Local Files’ tab
  4. Select the ‘Verify the Integrity of Game Files’ button
  5. When complete, close and reopen Steam

@FatsharkLev

Hello! That was the first thing I tried when my game was crashing with “files corrupted, mod yada yada” The file integrity came back okay, so I disabled all the mods and Vermintide 2 started working. I’ve tried several different things and i still can’t get a chat window to open.

Uninstalling and reinstalling is something I’m dreading to do. Please let me know if you have any other troubleshooting you’d like me to try. I’d appreciate it.

Thanks,
Vormar Mishap

In addition, the chat window was not showing last night during game. I was in a discord channel with 2 friends and they explained they where typing and nothing was showing up in Vermintide 2.

Hi @Vormar.Mishap

Sorry for the delayed response.

There are a couple of things worth trying here -

  1. Try opening the Chat by pressing on the numpad Enter that is hard bound to send a chat message
  2. Instead of rebinding manually, press the ‘Default’ button, which will reset all the keybinds to default.

This should help us to determine if the keybinds are wonky, or if there’s a deeper issue with chat that we’ll need to investigate.

Hello! @FatsharkLev ,

Thanks for the suggestions.

  1. The numpad enter did not open chat - I tried in solo game and with other players.
  2. My first post said I’ve tried the “default” keybind settings. I also tried again and it did not fix issue.

In the game I just tried, I noticed there isn’t a box in the lower left corner on the score countdown screen. I used to be able to click on that and type while waiting for next round. So something is definitely wrong with Vermintide 2 text box. The box shows up “sometimes” if a tome is picked up, or I get an achievement. However, I play with a 2 friends and we are in Discord, they pointed out to me that our 4th (unknown) player was typing and I couldn’t see any text. They had to read it to me in discord.

I’ll uninstall tonight, clean out the windows registry for the game, and reinstall. I hope that fixes it. I’ll let you know as I continue to troubleshoot.

Thank you,
Vormar Mishap

@FatsharkLev

Well, uninstalling and reinstalling didn’t fix it. I did use an uninstaller program to remove all the leftover folders and stuff in the registry. My keybinds stayed the same, which is weird because I thought I cleaned out everything. (guess it misses hidden folders if I dont include that option)

I found some other data on my bootup SSD under a hidden file area
%AppData\Roaming\Fatshark\Vermintide 2

And I renamed save_data to save_data_old along with some other config files. I used steam to validate all files and noticed it didn’t download a new copy of those files. I had to start the game before new ones were made.

After all that, I started game and intro movie along with tutorial (skipped all that) and my keybinds were gone. I was hoping that would fix the problem but, I still don’t have anyway of opening a text box. I tried a solo game and joined a multiplayer game to see if I could type. Nada…

Resetting to Default keybinds or changing keybinds didn’t work. Please help , I’m out of ideas.

Thanks,
Vormar Mishap

1 Like

Hey @Vormar.Mishap

That is incredibly strange! Could you please provide us with your most recent Console Log?

We’ll have to dig a little deeper, as it’s possible something odd is happening and disabling your chat somehow.

To do so:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Vermintide 2\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload* the appropriate console log to us

Thank you in advance :slight_smile:

Hello @FatsharkLev ,

I sent you a private message with the last 2 days of my console log. It was 3.94 mb.

Please let me know if you guys find a fix. Its difficult not having the chat box in game.
Vormar Mishap

1 Like

I also just noticed that my social wheel is not sending messages either. I see when I pickup art but I used “come here” command 3 times before I picked art up and there was nothing posted in text box.

update I spammed “help” from social wheel with a few friends online. They could see the message but it didn’t update in my text box. And I can only see those messages after I pick art or something up or complete a challenge.

Hm, so we have a theory that your Disable Chat user setting is being forced to True for some reason.

Could you please send us your ‘user_settings.config’ file?

To do so:

  1. Press the Windows key + R
  2. Enter %appdata% and select the ‘OK’ button
  3. Navigate to AppData\Roaming\Fatshark\Vermintide 2
  4. Copy and send the file to us

Thanks!

1 Like

Hello @FatsharkLev ,

I sent you another private message with my user_settings.config file attached. I also went into file using notepad and saw “enable chat = false” I changed this to TRUE, saved it, put it back into V2 folder and it worked ! I have a chatbox now. How the hell it got changed to “false” is mystery but it’s fixed :slight_smile:
Thanks for all the help FatsarkLev and backend developers ! You guys rock

1 Like

Huzzah!! Great to hear that :smiley:

No problemo, happy gaming! <3

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu