Javelin Bug - Non Refillable Ammo?

So I’m currently playing the sister of thorns on the latest update as of 11am US Eastern, June 4th. I’ve noticed that for whatever reason, the javelin ammo is completely unrefillable with both large and small ammo sources. Even looking at an ammo box directly, with no ammo left, no pop up even appears. The same happens when in game maps as well.

Considering that I’ve not seen anyone else mention this, I was starting to think that it may have been intentional- but if that was the case than I’d be pretty certain there would be people complaining about it on the feedback section, which I didn’t see either.

Restarting and starting the game, changing classes, changing ranged weapons, and changing characters does nothing for this. Switching my javelin from the blacksmith version to an actual made version also does not help, and neither does changing the illusion. (though it is worth mentioning that switching the range weapon in the keep does restore the ammo if you switch back to the javelin (as well as class switching. But the same problem of not being able to get ammo back from crates persists. Due to this, I think the game is simply not keeping track of the javelins ammo correctly, leading it to think it’s always full.)

Anyway. Thanks for your time~♪

Javlin functions the same as Bardin’s throwing axe.

Hold “R” to summon new ones.

Neither get to pick up ammo for them, you recharge it.

This should be explained better in game, it is not obvious or intuative at all.

6 Likes

Thanks alot~ I was completely unaware.

1 Like

When Bardin’s axes first came out I ran several missions before I acidently tried to reload while using them.

Was one of those eurika moments where Led Zeppelin - Immigrant Song started playing in my head and I ran around like a crazed slayer throwing axes at everything.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu