How to stop Darktide auto-changing settings on GPU detect?

Issue Description:
I use my system for a lot of workstation tasks (Blender, for example), and I have a dual GPU set up for this - one main GPU, and a small low power GPU I toggle the monitor over to when I need to free up as much processing power and VRAM as possible on the big card.

However, if after doing work I then forget to toggle the monitor back to using the main card… well, when I boot up Darktide, it overrides all my graphics settings back to a preset, which then means I have to spend a few minutes trying to remember what they were. This is far more tedious than if I could just disable the auto-detect and realise for myself that I’ve got the wrong GPU connected (trust me, I’d notice the terrible frame rate).

TL;DR: I want to lock things out so that the game will no longer auto-detect my GPU (or will at least not change my settings if it does)?

You could try making some manual changes in your user_settings.config:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Open user_settings.config
  5. Change adapter_index = 0 to adapter_index = 1
  6. Save your changes

I have attempted the above instructions, but it hasn’t stopped the autodetect.

Adapter_index seems to be being reset to 0 by the game itself, as it seems to have a last modified time more recent than when I would have made the change.

Do I need to make the file read-only, or will that have side effects?