Model for the stub revolver breaks sometimes?

Issue Description:
I was playing as a psyker in the meatgrinder, and equipped a stub revolver that I had just gotten as a gift from the Emperor. When I pulled it out though, there was no “gun” part of the gun, just a handle with floating bullets. I tried changing the skin on the weapon, changing to my melee and back, and going to the box and swapping the gun out for a staff and back, none of which fixed it.

Steps to Reproduce:
Step 1: Go to the Meatgrinder (potentially as psyker in particular, unsure if this works on other classes)
Step 2: Equip a stub revolver
Step 3: ???
Step 4: Profit


Player ID:

Approx. Time of Issue & Timezone:
01/06/2023 4:00am EST

Reproduction Rate:
Once, have not done further testing myself

Upload Supporting Evidence:

1 Like

My long history with firearms has taught me that using a firearm that does not possess a chamber might be just a tad dangerous.

That said, wow. Nice touch on hollow points guys!


Thank you for the report, @BlackBirdXI ! Did the issue fix itself when you closed and re-opened the game, or are you still having it? Any chance you could upload the console log corresponding to the play session where this happened? As well as your launcher log file?

These may be found by doing the following:

Upload Console Log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here

Upload darktide_launcher.log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Locate the darktide_launcher.log in this directory
  5. Upload here

The issue fixed itself when I rebooted the game, and I have not seen it since, though I have seen images from other players on the Discord server. Interestingly, this didn’t occur until the second time I switched to the revolver in that session inside the meatgrinder, but persisted until the game shut down. Attached below are the console log and the launcher log.

darktide_launcher.log (161.7 KB)
console-2023-01-06-07.43.51-dd350f20-b5d1-4a53-993d-c1878bf95da5.log (1.1 MB)