SOLVED | Crashing to desktop if clicking on map selector

Edit: in season2 beta i played the old haunts map. After going back to live the map selector seems to stuck on that non-existent map causing the game to crash if you click on the map selector. Redownloading the beta, selecting a live-version-existent map, pressing on start then logging into the live back again fixes the issue. @Fatshark_Hedge

Hey. I cannot select a different map in custom game. Disabled all the mods, i did integrity check after this i still crash to desktop if i click on the map selector. I can start the last custom game map (Grain) and i can start a quick play, but cannot select another map. The crash report is this:

GUID: 5742f36f-5447-47d9-9e82-02e713a3f75b
Log File:
Info Type:

[Script Error]: …t_game_view/windows/start_game_window_area_selection.lua:192: attempt to index local ‘settings’ (a nil value)

Have you finished a map since the error?

Speculation on

I assume finishing a DLC map without having the DLC might cause such a behavior at the next game.

Speculation off

Yes, i have. Many maps i’ve finished. I own all the dlcs.

Have you recently used the VT1 Style Map Selection (WIP) mod in the Modded Realm?

If so, try this:

  1. Install that mod.
  2. Go into Modded.
  3. Select Athel Yenlui.
  4. Quit the game.
  5. Go into Official.

If the issue is fixed, you can uninstall the mod.

The mod is bugged and it corrupts the current selected data if you select certain maps.

Nope I did not use map related mods not on live nor on modded. Just ui improvements, chat block, numeric ui, notice key pickup. On modded I use creature spawner, and onslaught. I used a quiet drink mod, but this issue happened long after I uninstalled that mod. I didn’t use quiet drink about a month now, and this issue persists like a week ago.

Had the exact same crash report when attempting to change the map for Custom Games.
I’ve never used any mods for the game nor have i even ran the game in the Modded realm, Whatever that is.

Recently found a patchwork solution which worked for me.
Windows Search bar > %Appdata% > Fatshark > Delete Vermintide 2.
You will have to re-do all your Settings & sit through the intro Prologue/tutorial which is a slight inconvenience.

As i mentioned previously, i haven’t used any mods so i can’t say how much data or settings from mods is stored in there along with the Base game, Do this at your own risk so to speak.

I hope this helps.
-Hugs & Kisses

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.