Sign-in Timeout Error

I bought the game on steam sale, and have not been able to play it yet, due to getting a “sign-in timeout error” every time I attempt to launch the game.

I have attempted:
validating game files
ipconfig /flushdns (/release, /renew)
restarting PC
changing my DNS server (to google’s public DNS servers)

Any help is apprecieated.

Having the same error.
Tried everything you did + VPN, to no avail.
Trying from Brazil, BTW.

Are you able to connect your PC to your mobile phone’s data (or any other method of bypassing the router), and see whether the errors in Vermintide 2 persist? I’d be keen to see whether your issues are router-related, but I appreciate that this isn’t always possible.

Not able to do that at the moment, however the issues does not happen to my wife, and her computer is on the same network as mine.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Same problem. It’s so dissapointing(

Why not join the Fatshark Discord https://discord.gg/K6gyMpu