Poor performance after Warrior Priest patch (or Microsoft Edge?)

I understand this is already a recognized issue, but I still felt inclined to post:
My PC/GPU is a bit old, but I’ve always enjoyed a very smooth experience (over 1,100 hours currently logged). I have always ran the game at 2K (2560x1440) resolution at high graphics settings. And I’m fairly confident that the game has always ran at about 60 frames (unless Sienna). After this most recent patch, however, the game has been suffering from FPS drops in the high-20’s during hoards and, even when the FPS counter is high (when at the Keep), the game hitches and micro stutters at a rapid and constant pace for me. Reducing the games resolution to 1080p, and graphics settings to their lowest, does not remedy the rapid stuttering. And hoards still drop my FPS to the low 30’s to mid 40’s. I have tried to disable the Steam Overlay, but this also did not improve the stuttering. I have tried reinstalling the game. I have not tried to uninstall Microsoft Edge (mainly because I don’t know how). I have also never used mods. Honestly, the only time I ever really had noticeable performance hits was from some fire effects from Wizard.

Intel Core i7-4790K CPU
16GB of RAM
GTX 980 GPU
Windows 10 64
Game is installed on a SSD

I also just checked the system requirements on the Steam store page and it appears I should still be within system specs.

1 Like

Thank you for your detailed report. I understand you’ve disabled the Steam Overlay, and do not play with mods, which is something we’ve been asking players to try.

There is no need to uninstall Microsoft Edge, as what was installed is merely a runtime (and not the Edge browser itself). If you think the runtime is causing issues, you could try our ‘Launcher Workaround’ by:

  1. Right-click Vermintide 2 in your Steam library
  2. Select ‘Properties’
  3. Select the ‘Betas’ tab
  4. In the dropdown, select ‘Temporary Launcher Workaround’
  5. Restart Steam
  6. Launch Vermintide 2
  7. Select the ‘Bypass Launcher’ option
  8. Click ‘Play’

Thats not true. Installing microsoft edge lowers overall fps and makes the games fps unstable.

We did not install Microsoft Edge - the browser - to your PC. It is a runtime.

Im aware that its not the browser, it still causes negative game changing problems.

Are you running Windows 7?

I also have micro stutters from time to time with constant 75 FPS (locked). Alt-tabbing once or twice fixes it for me.

what i really don’t get is, for what that edge update even is, its probably the first time i got a prompt to istall anything browser related, on an uptade to a game lol.

i can only assume that its twitch related?

WebView2 is a runtime redistributable that allows embedding web content in other applications, by providing an interpreter that allows execution of web code.
They reworked the launcher with links and videos, and it now basically is a webpage.
The problem with that is that you need a web browser to read the code, and they had 2 options : either they assume you have it installed or they package the code interpreter with the app.
Kind of like IKEA giving you screwdrivers and stuff to build your table, instead of assuming you have some.
The up side is that they are making sure it can run on everyone’s computer, the downside is that since most of us already have it (since I believe it’s included in win 10 and 11 by default), it takes some minor ‘useless’ disk space, kind of like the IKEA tools being duplicates of ones you already own.

Most if not all programmes do so today, be it runtime viewers, C++ redistributables, etc.

So in theory, this should not cause any issues. In practice though, most seem to have some performance losses that appear to get fixed by uninstalling their local edge (effectively dumping your own tools and only using the IKEA provided ones), so perhaps the client is running both runtimes or something ?

first thank you for the rundown,
and since i never installed it and still recognise some freeze frames here and there (since WP) it might not be related to this.

Yeah I’ve had some occasional freezes too that shouldn’t have happened, though they are really, really rare.
That being said, they are quite aggravated when I record the game (looks like the image freezes for a couple of seconds every minute or so), and it used to work perfectly smoothly so… I don’t know.
I don’t know if it is WP related, or just launcher related, or something else entirely.

same here. my machine is more than capable and ive always ran the game without problems but recently the FPS drops alot and the game stutters, usually below 50. garden of morr is especially bad

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu