Player actions failing to execute on wifi/packet loss

Issue Description:
when my computer is on a wifi connection, every player action has a small chance to start the animation/action for a split second, then fail as if it didn’t happen.

Steps to Reproduce:

  1. Be connected to a wireless network
  2. Be playing in an online game (I assume the Psykhanium uses solo/client side instances as I have not been able to reproduce this in those tutorial/sandbox modes)
  3. Easiest way to reproduce is to constantly press Q to weapon switch until it happens (for split second it looks like the weapon switched, but then it goes back to the current weapon), or to repeat the melee weapon block+follow up attack until that makes a similar issue occur.

Mission Name (If Applicable):
any mission that is online with other players

Platform:
Steam

Player ID:

Approx. Time of Issue & Timezone:
[11/19/2022, 10:04 PM] [UTC/GMT -6]

Reproduction Rate:
Rare (<10%)
I have my computer with a PCI express wifi card in a room far away from my wireless router. This bug occurs maybe every 15 or 20 seconds, it’s most noticeable when switching weapons or trying to perform certain melee attacks or combos.

I have a feeling this is related to packet loss when on a wifi connection. When I am on a wired ethernet connection, this issue does not occur, and it is harder to reproduce when I set up my computer on wifi right next to my wireless router

Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log:
console log is attached
console-2022-11-20-02.49.42-20b35e3c-c1e7-469e-854f-804190d70eab.log (410.0 KB)

i think it might be related to this error message here?
04:07:39.172 [Lua] INFO [PlayerUnitDataExtension] Panic started. Received state package from the future, this is likely because we haven’t run any fixed frames yet or had a major stall. Received frame (110273), last frame (110269).

Upload darktide_launcher.log:
launcher log is attached
darktide_launcher.log (315.0 KB)