KNOWN ISSUE: Unable to Save Loadout/Talents, Reverting to Previous State

We are working on an issue in which players are unable to save Loadouts/Talents.

Upon saving, your operative will revert to its previous state.

This occurs when 2 of the same Curio are equipped in separate slots.

This should not be possible, and is something we’re working on preventing.

In the mean time, you can work around this by unequipping the duplicated Curio.

New reports may be merged here, to help us keep track of the issues being reported.


If I may add my 3 cents:

It was also occurring when after spending points in one tree, player moved to cosmetics or loadout tab without spending points in other empty trees (I’ve had 4 empty subclasses).
After I’ve set up all points (without changing tabs - just moving through saved “subclasses”), points remained in the trees and red exclamation points disappeared.

I don’t think it was curio related - I’ve had 2x 17% toughness curios(different rating each, not a copy) and a +1 wound curio.

At least I think that was the case.

1 Like

This triggered on adjusting cosmetics for me without touching curios as well, but I’m unable to consistently reproduce. The workaround for me was to change cosmetics back and forth on some saved loadouts, not curios.


i bypassed this issue by leaving the 5th loadout unmade
everytime i make a new loadout i save it by copying it as the 5th loadout, then redeleting the 5th loadout to only keep the forced saved loadout (by copy, i mean being on a loadout page and clicking the upper right hand corner plus sign cuz clicking the plus sign for some reason brings you the same loadout and not a fully mint unused loadout page like a real game)

(my mentality is that to copy and paste the loadout, the system essentially needs to save it before transfering it to lessen risk of file corruption or at the very least officially tells the system that you do in fact have a new build) 100% success rate

Veteran loadout bugged, cannot switch out.

Happened randomly one day, makes game unplayable and unprogressive


**At rank 22 **

Reproduction Rate:
Constant (100%)

Only info I have is I purchased KRIEG set for veteran, and it may be linked to account.

[PC] Upload Console Log & darktide_launcher.log:
[Instructions: How To Provide a Crash Report, Console Log, or darktide_launcher.log]

1 Like

Had this happen a lot lately, especially on Veteran.
For me, it was always solved by switching the curios around so they were the same ones, in the same order, as another loadout that actually worked.
… though that would mean that once they are all bugged, there is no saving them.
Unless you mean you can’t click on the others at all, in which case, ncm, different bug.

1 Like

Thank-You :slight_smile:

i noticed this happening recently but it is not that i cant save the loadouts. it is that the game is pairing the wrong skill tree with the wrong loadout
i often find myself going into missions with weapons and curious from a different loadout which is incredibly annoying, especially when you build your skill tree around using a certain weapon etc.
has it happen on psykter and veteran, taking the wrong staffs and swords into missions etc. really annoying, seems to fix itself tho randomly. only happens randomly after changing stuff

i have had the bug regardless of fifth loadout or not. on my vet i only have 2 loadouts right now. and just experienced the bug where i took the wrong weapons into the mission

I actually cannot unequip one of my Curios, and I have a similar UI bug which won’t let me change my talents and loadouts. I also can’t make a new loadout or change the icon for it.

1 Like

Suffering from this issue on just my veteran at the moment. Loadouts revert to the last three I had from the last update. (The Traitor Curse Part 1) and don’t update after I restart the game or change characters.

The work around of unequipping curios doesn’t work.

console-2023-12-07-16.33.33-9bc71f12-ec66-4708-bf7f-70be8ea33d83.log (62.0 KB)

Issue Type (Required):


Issue Description (Required):

For several weeks now, I’ve been unable to edit any loadout for any character in the game. Even when I create or delete a loadout, the changes are reversed after the next launch of the game client.

Regrettably, this issue is quite disruptive and frustrating. It compels me to remember all my loadouts mentally, as I have to edit them manually each time I start the game. This problem significantly diminishes the enjoyment I derive from playing Darktide.

Steps to Reproduce (Required):

  1. Launch the game.
  2. Choose a character.
  3. Edit a loadout/Delete a loadout/Create a loadout.
  4. Defeat some Heretics with the edited loadout.
  5. Verify if it’s still the correct loadout afterward (Spoiler: Yes, it is).
  6. Restart the game.
  7. All loadouts for all characters are reverted.

[PC] Do You Use Mods? (Optional):

Yes, and I’ve tried disabling them

Reproduction Rate (Required):

Constant (100%)

Platform (Required):

PC - Steam

Player ID (Optional):

[PC] Upload Console Log & darktide_launcher.log (Optional):

console-2023-12-13-20.01.58-5322b67b-3195-43af-be8c-6e3f63e4557a.log (1.42 MB)
console-2023-12-23-19.01.14-6beeb539-9937-494b-80fa-00436a4d2ba9.log (1.04 MB)
console-2023-12-13-02.13.33-90ca971b-faad-4c01-9dbc-741ccc8a145c.log (1.95 MB)
console-2023-12-16-22.16.43-f0629ed3-5bdc-453a-836b-8c843496dee0.log (1.75 MB)

I made an effort to figure out how to avoid this problem, and I’d like to share some more detailed information about it. Here’s a brief description of what I’ve noticed so far:

Upon starting the game, I selected my main character with 5 loadouts. I edited one loadout and played a mission. After completing the mission, the loadout remained the same as I edited, whether I checked it in the inventory or attempted to edit it again—no issues so far.

However, when I returned to the main menu or restarted the game (it doesn’t matter which), the loadout was still the same as the one I edited and used in the mission before. Only when I accessed the inventory, skill tree, gear screen, or anything like that did all loadout slots reset. Deleted slots reappeared as if they were never deleted, and every other loadout slot reverted to how it was before I edited it in the previous session.

Interestingly, when playing a character without any loadouts, there is no issue.

In conclusion, it appears to be a problem with saving the character’s loadout data before the game shuts down.

I hope this information helps you address the issue because it’s not really enjoyable to play with this bug.

Suggestion: Perhaps a temporary solution could involve providing a button in the settings for a hard reset of all loadouts?

Can report the issue still persists after the recent patch.