KNOWN ISSUE: Input Lag, Actions Not Registering Correctly

Is there any update on this fatshark a lot of people are having this problem and absolutely nowhere have I found anyone providing a solution.

1 Like

I have the exact same issue.
Can’t switch weapons, have to hit the input about 2-5 times to make it actually switch and sometimes my guns or weapons do not do the correct input like blocking or charging up an attack, etc.

Been dealing with this since launch. Oddly enough I played the beta and this issue was not present.

I had tried turning off/down some graphical settings thinking it was something to do with that since I had a lot of my settings on high. But even with most settings either disabled or a low as they will go I still get the same issues. I don’t have this problem on any other game either. Just this one. I love it when it works but with this bug happening it feels really really janky.

Game is unplayable Julia please communicate this is crap. Paid 60 bucks and can’t even play the game!

Issue Description:

In-game, after a few minutes or sometimes even seconds, I suffer from what I could only describe as input lag. I can’t always swap weapons, I have to press the key multiple times for it to work, although I see the beginning of the switching animation each time, it just reverts to the first weapon.

When I fire Psyker’s staffs or firearms it “stutters” (for example, the surge staff is stuck in a looping casting and releasing animation and I have to left click multiple times for the staff to actually fire. And if I use something like the Bolter, sometimes it won’t fire, sometimes only one round while in hip fire.) The sprint or slide keys are also very rarely responding, I begin to sprint, but immediately stop.

I also noticed that my character animation is stuttering while walking left or right on the Mourningstar (not using the keyboard’s left or right inputs, just moving the mouse left or right.

Steps to Reproduce:

Playing the game.

Platform:

Steam

Player ID:

Approx. Time of Issue & Timezone:

Started around the release of the 1.0.20 hotfix, getting worse since.

Reproduction Rate:

Constant (100%)
console-2022-12-24-10.34.35-065e3158-ef58-4b03-95f0-fddf9ebb5925.log (153.2 KB)

darktide_launcher.log (110.1 KB)

I would like to add that I have no issue playing the prologue and moving in the Mourningstar when it’s a private instance (before the tutorial).

Tbh sounds like a connection issue to me.

I´ve the same with weapon-swap sometimes (maybe once a every 1-2 games) and it either feels like canceling by pressing “block” too fast or something, dunno. Other times i just spam LMB in melee and i suddenly do a heavy attack.

Might even be the missing feature from V2 to safe your inputs for 0,5s or so. But in your case it sounds like typical lags when it´s pretty much everywhere, especially if it wasn´t a thing in the tutorial. I guess it´s an own instance on your PC and not server-related like the rest of the game.

I think so, but I don’t know why it’s only happening in Darktide and not in other games. And it started happening a week ago after more than 100 hours of playtime.

And also : I don’t have rubberbanding, enemies and other players are acting without any visible latency or hiccups.

I’ve sent this over to our developers. Thank you.

Thank you very much.

Yep i confirm this. Happend to me everytime huge horde comming. I cant swap weapon that’s for sure kind of frustrating if not prepared x)
Server lags in some situation due to game not well optimised yet.

In addition to weapon switching issues, I’ve also had instances of shooting the Grenadier Gauntlet where I hear the sound, see the projectile shoot, but no explosion, no damage, and no ammo used.

Having the same issues no fix in sight! Game is unplayable like this. I even tried to reformat and that did nothing for this issue. All is quiet on the fatshark side they must be working on new cosmetics or something.

Game works fine in the psychanium thing 0 issues whatsoever.

I can create rubberbanding and hit reg stutter 100% of the time (gun starts stuttering) by simply moving at the same time I’m firing an Agripinaa Mk VIII braced autogun on my zealot. Something is seriously up with the servers.

Game is basically unplayable since most actions that require a singular action dodge, weapon swap, heavy attacks and sprint if you use toggle to name a few register on my client side and start doing the animation, but in a fraction of a second just says no and cancels it so changing weapon to block? no you just ads, dodge to avoid a hit? no you just teleport back to the position where you would have gotten if you only strafed in to the direction. you want to chain heavy attacks? no you just stop chaining them and stand there looking like a idiot and start to cry when an enemy hits you when he would’ve been staggered by the hit and unable to hit you.
what can i do to fix this issue ?
I have restarted my router and pc, reinstalled the game, changed my router/internet settings and tried with a VPN but with no luck of resolving the issue.
it got a lot worse after the release, I didnt have much issues in the beta but now its basically unplayable and feels like its tied to the time the game is running but that could be just luck… sometimes it can get so bad i literally have to change my firearm SIX times to a melee till it goes trough and take a lot of dmg in the process…

2 Likes

I’ve raised this with our developers. Thank you.

i have this same problem i assume. If i am charging staff on psyker, ESPECIALLY during horde, it will take multiple left clicks to release the charge. Sometimes it wont start the charge, or it will drop the charge completely. with melee, it will drop my block, or not follow through with the push, or push attack. Sometimes it will not alow a heavy and i just have to spam left click. Regularly if i am swinging or shooting, my dodges will not properly follow through. for some reason, i can always get head pops off though. As soon as there is ‘wave mechanic’, everything falls apart. ive tried altering worker threads, tried swapping my physx from cpu to gpu to auto. i have a brand new PC i bought just for darktide, with 3500 hr in verm 2 and 250 hr in verm 1. During pre-release i was crashing 2-5 times per mission. That is gone now, and i think it might be the nvidia driver that came out with game release?

sometimes when im in the lobby, and im running straight, my character will wobble all over like mad desync. i have 1.5 gig internet down and 900meg up.

the strangest part is that ill be sitting at 120 fps the ENTIRE TIME, with noone else in the house using the internet.

i call it desync when i mention it in games, because its as though my inputs are being lost as soon as action is happening, and it is not related to fps drop or bad ping.

1 Like

It’s getting worse every new day, used to be that one game, now it’s practically every game

Indeed the “inputs” are clearly worse than in the beta. Since the last patch the game runs again on my machines, but the inputs are still an issue.
Thank you for raising this point.

Also don’t know if its related or not, but while I was playing I tried changing VPN on and locations aswell, while I did expect a disconnect I did not expect the whole server to start lagging like its run on a 2g connection… atleast thats what my friends said that were still on the server and it was repeatable, while I was in the server if i changed my VPN the game lagged me out and gave errorcode 2003 I think which is to be expected, but at the same time my friends who were still on the server underwent some insane lag aswell which I dont know why it does that since its not a peer to peer hosted game…