"Disable screen shake" does not work

Issue Type (Required):

Visual

Issue Description (Required):

Special players dealing damage to heroes still causes their screens to shake even if it’s disabled in the options. It’s extremely annoying in my opinion.

Steps to Reproduce (Required):

Enemy special player deals damage to you (hero)

Reproduction Rate (Required):

Constant (100%)