Constant random crashes, tried everything

I keep getting random crashes to desktop, sometimes with an error other times without, it can happen within 5 minutes or it can take an hour to happen.

I tried everything on the forum and knowledge base, i’ve tried running all my hardware at stock clocks and voltages, i repaired the game, directx, .net framework, c++ libraries, windows file system, i tried reinstalling drivers (video, chipset…etc), i tried different thread counts, dx11 and dx12, i even tried playing on a different user account, but all i get is crashes to desktop.

The error can show up as .NET Runtime accompanied by a KERNELBASE.dll in event log, other times there’s nothing.

These are the crashify errors that i managed to save:

GUID: 802db8b2-ef0a-4ca5-8cae-fb95f3c12d9d
Log File:
Info Type:

GUID: 96a2065c-58aa-42e3-b785-b3f6feb2b914
Log File:
Info Type:

Either i lack viewing permission or there are no logs O_O

But those random crashes, since you mentioned trying everything i assume you´ve disabled mods? Some of them have been known to cause CTD´s.

tried with mods disabled.

I just backflashed my BIOS but that’s a really far fetched excercise.

That it is, i gave google a quick look and the only similar thing i found that got solved was a case where a dude had a GPU that didnt like VT2 in particular for some reason.

He uploaded logs which revealed that though, do you know where to find yours?

which logs are we talking about?, crashify or windows event viewer?

Game tries to save logs for each session you play and each time the game crashes if possible.

You can find them in under Drive → User → *PC username * → Appdata → Roaming → Fatshark ->VT2

1 Like

Funny enough I got a random crash out of the blue which seems to look similair to your crash.



The above pictures I had to take out of the reliability history in windows because I got no error code.

I’m not sure if this is usefull but just thought I’d share a similair experience.

Might be completely unrelated but I had KERNELBASE.DLL errors linked to my motherboard’s integrated GPU and the game (RDR2) being stupid about which to use.
A fix that worked was to deactivate the integrated GPU, even though it was definitely not a satisfactory one.
As Frostysir said, you should upload the game logs (you can access the folder by pressing [windows key + R] and typing %appdata% in the run window), so that Fatshark can analyze them and hopefully fix the issue.

I’ve responded to your submission via the Support Portal with a couple of questions.

Hi Julia, i responded to the ticket.

From a couple of days of testing, it seems that a negative curve in PBO curve optimizer is that culprit, even though the system was fully stable (no BSOD or WHEA errors in event viewer), i will test for a couple more days to confirm this.

No crashes so far, seems like the curve optimizer was the reason.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord